[B2G] Enabling Voice input in Firefox OS -- Grammar based app (phase 1)

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: skamat, Unassigned)

Tracking

(Depends on 2 bugs, {feature})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [webspeechapi])

User Story

This is a phase 1 of the larger user story in bug 1032964
---

As I user, I would like to have a support for voice input on my FxOS device for executing various actions on device, as well as fetching info from the cloud.

-The action words that the use can say are pre-identified and indicated to the user via UX. (such that the recognition complexity of this phase would be less compared to natural language processing). 

-Each action would be recognized and the device UX will confirm with the user on success and failure as defined in UX specs.
This bug is to track phase 1 of below meta bug 1032964

Scope: 
- Grammar based Voice input app (phase 1) 

+++ This bug was initially created as a clone of Bug #1032964 +++

As I user, I would like to have a support for voice input on my FxOS device for executing various actions on device, as well as fetching info from the cloud.

Current thought is to break it down into 2 phases
phase 1: Grammar based, local actions
phase 2: Natural lanaguage, server assisted actions

This will be used as a user story meta bug to track dependent work items.
User Story: (updated)
Blocks: 1032964
Depends on: 1051118
Depends on: 1051123
Depends on: 967896
Depends on: 1051130
Depends on: 1051137
No longer depends on: 1051137
Depends on: 1051146
Depends on: 1051148
No longer depends on: 1051130
No longer depends on: 1051146
Depends on: 1051554
No longer depends on: 1051554
Depends on: 1051604
Depends on: 1051146
No longer depends on: 1051123
No longer depends on: 967896
Depends on: 1060659
Depends on: 1065904
Depends on: 1065911
No longer depends on: 1051146
No longer depends on: 1051148
No longer depends on: 1065911
No longer depends on: 1060659
Depends on: 1051146
Depends on: 1060659
Depends on: 1051148
Depends on: 1067683
No longer depends on: 1065904
Depends on: 1067689
No longer depends on: 1051148
No longer depends on: 1051146
No longer depends on: 1051604
No longer depends on: 1060659
Whiteboard: [webspeechapi]
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: Meta-Vaani
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Andre why is this not a duplicate.
Flags: needinfo?(anatal)
(In reply to kdavis from comment #2)
> Andre why is this not a duplicate.

Why open a new bug over the original one opened almost on year ago?
Flags: needinfo?(anatal)
I guess I don't care which one we keep. But at least:

1. There should be one open bug for Vaani, not two as there currently are
2. The surviving bug should depend the correct bugs (Bug 1172878, Bug 1172879, Bug 1172881...)
3. The surviving bug should link to the correct specs (Visual Spec, User Flows...)

Beyond that, you can decide on which to keep.
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 4 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.