Clean up MP4 range calculation

RESOLVED FIXED in mozilla34

Status

()

Core
Audio/Video
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: kentuckyfriedtakahe, Assigned: kentuckyfriedtakahe)

Tracking

Trunk
mozilla34
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 2 obsolete attachments)

The MP4 range calculation has become messy and requires some clean up.
Created attachment 8468998 [details] [diff] [review]
Clean up MP4 index fields
Attachment #8468998 - Flags: review?(edwin)
Created attachment 8468999 [details] [diff] [review]
Update index off main thread
Attachment #8468999 - Flags: review?(edwin)
Created attachment 8469000 [details] [diff] [review]
Optimise MP4 range calculation
Attachment #8469000 - Flags: review?(edwin)
Created attachment 8469001 [details] [diff] [review]
Fix MP4 range pinning
Attachment #8469001 - Flags: review?(edwin)
Created attachment 8469002 [details] [diff] [review]
Fix 64 bit file offset in MP4 reader
Attachment #8469002 - Flags: review?(edwin)
Created attachment 8469005 [details] [diff] [review]
Fix MP4 range pinning
Attachment #8469005 - Flags: review?(edwin)
Attachment #8469001 - Attachment is obsolete: true
Attachment #8469001 - Flags: review?(edwin)
Created attachment 8469060 [details] [diff] [review]
Optimise MP4 range calculation
Attachment #8469060 - Flags: review?(edwin)
Attachment #8469000 - Attachment is obsolete: true
Attachment #8469000 - Flags: review?(edwin)
Comment on attachment 8468998 [details] [diff] [review]
Clean up MP4 index fields

Review of attachment 8468998 [details] [diff] [review]:
-----------------------------------------------------------------

::: media/libstagefright/binding/Box.cpp
@@ +57,5 @@
>      mChildOffset = headerRange.mEnd;
>    }
>  
>    MediaByteRange boxRange(aOffset, aOffset + size);
> +  if (mChildOffset > boxRange.mEnd ||

Since boxRange is [), this should be |>=|.
Attachment #8468998 - Flags: review?(edwin) → review+
Comment on attachment 8469060 [details] [diff] [review]
Optimise MP4 range calculation

Review of attachment 8469060 [details] [diff] [review]:
-----------------------------------------------------------------

::: media/libstagefright/binding/MoofParser.cpp
@@ +56,5 @@
>  MoofParser::ParseMdia(Box& aBox, Tkhd& aTkhd)
>  {
>    for (Box box = aBox.FirstChild(); box.IsAvailable(); box = box.Next()) {
>      if (box.IsType("mdhd")) {
> +      if (aTkhd.mTrackId == aTkhd.mTrackId) {

um...?
Attachment #8469060 - Flags: review?(edwin) → review+
Duplicate of this bug: 1052926
Blocks: 1053124
You need to log in before you can comment on or make changes to this bug.