If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Double Click on tree view arrow toggles the children three times

RESOLVED FIXED in Firefox 34

Status

()

Firefox
Developer Tools: Performance Tools (Profiler/Timeline)
P3
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Sami Jaktholm, Assigned: Sami Jaktholm)

Tracking

unspecified
Firefox 34
Points:
---
Bug Flags:
in-testsuite +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Steps to reproduce:
1) Open profiler and create a profile.
2) Double click on the root item arrow

What happens:
- After click #1 the root item is expanded
- After click #2 the root item is first collapsed and then expanded again.

What should happen:
1) A double click on the arrow acts like a double click on any other part of the line (i.e. the arrow ignores the click events prior to dblclick event and toggles the expansion only once).
- Impractical as it requires the arrow to wait for a possible second click after every click before it can toggle the children.

2) A double click on the arrow acts like a two distinct clicks on the arrow: the first click expands and the second click collapses the children (i.e. dblclick on the arrow is ignored).

The current behavior causes unnecessary flicker and looks ugly especially if there's some time between the two clicks (but still within double click time limits).
(Assignee)

Comment 1

3 years ago
Created attachment 8469181 [details] [diff] [review]
profiler-treeitem-dblclick-expand.patch

Here's a patch that makes the treeview to ignore dblclick events on the expander arrow. It also contains a test case.

Try run: https://tbpl.mozilla.org/?tree=Try&rev=a6c345725cb8
Assignee: nobody → sjakthol
Status: NEW → ASSIGNED
Attachment #8469181 - Flags: review?(vporof)
OS: Linux → All
Priority: -- → P3
Hardware: x86_64 → All
Nice.
Comment on attachment 8469181 [details] [diff] [review]
profiler-treeitem-dblclick-expand.patch

Review of attachment 8469181 [details] [diff] [review]:
-----------------------------------------------------------------

Nice! Thanks!
Attachment #8469181 - Flags: review?(vporof) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/b5345b8463af
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/b5345b8463af
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 34
Flags: qe-verify+
Setting qe-verify- since we have a test for this in browser/devtools/profiler/test/browser_profiler_tree-abstract-04.js.
Flags: qe-verify+ → qe-verify-
You need to log in before you can comment on or make changes to this bug.