Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 140613
17 years ago
13 years ago

People

(Reporter: Henrik Gemal, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
In a folder of mine I've got some mails that doesn't thread. It's pretty weird. 
All the other mails thread just not these 3 mails. I'll attach a screenshot.

build 20011015
(Reporter)

Comment 1

17 years ago
Created attachment 53729 [details]
3 mails not threaded
(Reporter)

Comment 2

17 years ago
The subject of the mails that doesn't thread is:
[Bug 104841] Getting "02 I can't get your name.  Goodbye."

could it be because of the ' in the subject? I'me not sure how mozilla is 
determaning to thread a message or not

Updated

17 years ago
QA Contact: esther → laurel

Comment 3

17 years ago
reassigning to bienvenu.  I've tried this out and this exact same subject
threads for me if I send myself 2 different messages with the same subject/
Assignee: sspitzer → bienvenu
(Reporter)

Comment 4

17 years ago
Is the threading saved somewhere? Like in the msf file? Or is it done on-the-fly
when opening a folder?
(Assignee)

Comment 5

17 years ago
threading is saved in the .msf file. We thread by subject for mail folders but
not for newsgroups. Is this a mail folder? This works fine for me, so I can't
reproduce it. If you move away your .msf file, are the messages threaded
together correctly?
(Reporter)

Comment 6

17 years ago
when I deleted the msf file it threaded ok. I'm attaching the corrupted msf 
file. The problems subject was:
"Custome header" filter not working if rules.dat is copied
(Reporter)

Comment 7

17 years ago
Created attachment 54744 [details]
msf file where two mails with "Custome header" in subject didn't thread
(Reporter)

Comment 8

17 years ago
is there a checkmsf file util that can detect corrupted msf files? Or how do I 
detect corrupted msf files?
(Assignee)

Comment 9

17 years ago
I was not suggesting that the .msf file was corrupt, just that the threading was
wrong. To figure this out, we'd need a reproducible case, i.e., one where
deleting the .msf file and regenerating it would exhibit the same bug. I can
look at the .msf file but I doubt that it's corrupt.

Comment 10

16 years ago
We're doing a general bug cleanup... anything to add about resolving this bug?
(Assignee)

Comment 11

16 years ago
I believe this is a problem with mork, and/or the way we do subject threading.
I've seen this happen in the debugger a few times. What seems to happen is if
you delete all the messages in a thread, and then get a new message with the
same subject as the message(s) in the thread, and then get a second message with
the same subject, we think the second message belongs in a thread by itself
because there's a phantom thread object returned by the FindRow call in
nsMsgDatabase::GetThreadForSubject(nsCString &subject). FindRow can only be
called if the column you're searching on is unique in the row space. It is, but
I suspect that having the empty thread causes problems somehow. This is all to
say why deleting the .msf file fixes the problem, because the empty thread is
deleted with the .msf file. I'll look into finding a reproducible case and see
if I can figure out what's going on.
Status: NEW → ASSIGNED

Comment 12

16 years ago
I've started seing this on Linux recently, so marking OS:All
OS: Windows 2000 → All

Comment 13

16 years ago
Isn't this a dupe of bug 140613 which is now Resolved-Fixed?
(Assignee)

Comment 14

16 years ago
yes, it's a dup.

*** This bug has been marked as a duplicate of 140613 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 15

16 years ago
Thanks! Marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.