Closed Bug 1050243 Opened 10 years ago Closed 10 years ago

Assertion failure !mozilla::ipc::ProcessingUrgentMessages() at dom/events/EventDispatcher.cpp when running webconsole mochitests

Categories

(Core :: DOM: Content Processes, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s m6+ ---

People

(Reporter: msucan, Unassigned)

References

Details

(Keywords: assertion, crash)

I'm trying to run the webconsole mochitests in e10s mode (patch from bug 1042253) and I'm getting a tab crash:

https://pastebin.mozilla.org/5854108

Two days ago the tests ran with no issues. Now every test causes the crash. I cannot reproduce manually by starting Firefox with e10s enabled, loading a page with devtools open works.

Any ideas what's happening?
More testing shows that the new crasher comes with this m-c merge into fx-team:

https://hg.mozilla.org/integration/fx-team/pushloghtml?startID=8088&endID=8089
Looking into the pushlog linked in comment #1 I see some patches related to the message manager, CPOW, etc. Can you please look into this crasher? It is blocking my work on bug 1042253. Thank you!
Flags: needinfo?(wmccloskey)
Well, this is a bug in the how CPOWs work. However, developer tools really shouldn't be using CPOWs at all. Unfortunately, it's really easy to accidentally use them because common getters like window.content automatically return CPOWs. I'll see what I can do about addressing this.
Flags: needinfo?(wmccloskey)
I filed bug 1051017 to make it much less likely that we'll end up using CPOWs by accident in places like this. Unfortunately, the patches in that bug make it impossible to even open the developer tools in e10s. Mihai, do you think you would have time to look into this? I'm hoping we just need to fix a few things in target.js. The STR for the breakage is: 1) apply the patches in bug 1051017, 2) open an e10s window and open the web console.
Flags: needinfo?(mihai.sucan)
(In reply to Bill McCloskey (:billm) from comment #3)
> Well, this is a bug in the how CPOWs work. However, developer tools really
> shouldn't be using CPOWs at all. Unfortunately, it's really easy to
> accidentally use them because common getters like window.content
> automatically return CPOWs. I'll see what I can do about addressing this.

You are right, it's very easy to accidentally use cpows. However, please fix the crasher because this is making it much harder for me to work on bug 1042253 - I'm stuck in the fx-team revision before the m-c merge I mentioned in comment #1.


(In reply to Bill McCloskey (:billm) from comment #4)
> I filed bug 1051017 to make it much less likely that we'll end up using
> CPOWs by accident in places like this. Unfortunately, the patches in that
> bug make it impossible to even open the developer tools in e10s. Mihai, do
> you think you would have time to look into this? I'm hoping we just need to
> fix a few things in target.js. The STR for the breakage is: 1) apply the
> patches in bug 1051017, 2) open an e10s window and open the web console.

Thanks for the ping on this issue. I will try to look into the problem, however I cant promise anything. I'm currently working intermittently due to some health issues. You may want to also ask other team members.
Flags: needinfo?(mihai.sucan)
Bill: is this bug actionable? Does this bug require a CPOW fix or a webconsole fix? It's unclear from the comments.
tracking-e10s: --- → m6+
Flags: needinfo?(wmccloskey)
Keywords: assertion
Summary: Assertion failure !mozilla::ipc::ProcessingUrgentMessages() at dom/events/EventDispatcher.cpp → Assertion failure !mozilla::ipc::ProcessingUrgentMessages() at dom/events/EventDispatcher.cpp when running webconsole mochitests
This assertion has been removed.
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: needinfo?(wmccloskey)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.