Intermittent test_visibility.py TestVisibility.testShouldShowElementNotVisibleWhenParentElementHasHiddenAttribute | TimeoutException: TimeoutException: Connection timed out

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({intermittent-failure, pi-marionette-intermittent})

Trunk
ARM
Gonk (Firefox OS)
intermittent-failure, pi-marionette-intermittent
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
b2g_emulator_vm mozilla-inbound opt test marionette-webapi on 2014-08-07 07:36:34 PDT for push b7960f3ec637

slave: tst-linux64-spot-194

https://tbpl.mozilla.org/php/getParsedLog.php?id=45424067&tree=Mozilla-Inbound

{
08:00:18     INFO -  08-07 10:54:15.166 I/Gecko   (   44): MARIONETTE LOG: INFO: TEST-START: /builds/slave/test/build/tests/marionette/tests/testing/marionette/client/marionette/tests/unit/test_visibility.py:testShouldShowElementNotVisibleWhenParentElementHasHiddenAttribute
08:00:18     INFO -  08-07 10:54:15.186 I/Gecko   (   44): 1407423255187	Marionette	INFO	sendToClient: {"from":"0","value":null}, {bec6798d-9b63-4e05-9e64-7069ae77a4fa}, {bec6798d-9b63-4e05-9e64-7069ae77a4fa}
08:00:18     INFO -  08-07 10:54:15.396 E/GeckoConsole(   44): [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://10.134.157.239:49538/hidden.html" line: 0}]
08:00:18     INFO -  08-07 10:54:15.596 I/Gecko   (   44): 1407423255602	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {abf24ddc-710a-4926-b05c-b4b61757ef0b}, {abf24ddc-710a-4926-b05c-b4b61757ef0b}
08:00:18     INFO -  08-07 10:54:15.656 I/Gecko   (   44): 1407423255646	Marionette	INFO	sendToClient: {"from":"0","value":{"ELEMENT":"{2e7c21a7-732c-4299-bd02-a91b2fba9391}"}}, {8cfb023c-28ad-4f32-9a21-bfc3b3b2c3f1}, {8cfb023c-28ad-4f32-9a21-bfc3b3b2c3f1}
08:00:18     INFO -  08-07 10:54:15.746 I/Gecko   (   44): 1407423255747	Marionette	INFO	sendToClient: {"from":"0","value":false}, {7cf3770a-bfea-4d2a-9c2a-a549ac80aa42}, {7cf3770a-bfea-4d2a-9c2a-a549ac80aa42}
08:00:18     INFO -  08-07 10:54:16.226 I/Gecko   (   44): 1407423256233	Marionette	DEBUG	Got request: setContext, data: {"to":"0","sessionId":{"rotatable":true,"browserVersion":"34.0a1","takesScreenshot":true,"appBuildId":"20140807062415","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","secureSsl":false,"platform":"ANDROID","browserName":"B2G","version":"34.0a1","device":"qemu","b2g":true,"nativeEvents":false,"platformVersion":"34.0a1","takesElementScreenshot":true,"platformName":"ANDROID","handlesAlerts":false},"name":"setContext","parameters":{"value":"content"}}, id: {a4c28fe5-cf29-4635-a6d2-53c94cefbfd7}
08:00:18     INFO -  08-07 10:54:16.226 I/Gecko   (   44): 1407423256235	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {a4c28fe5-cf29-4635-a6d2-53c94cefbfd7}, {a4c28fe5-cf29-4635-a6d2-53c94cefbfd7}
08:00:18     INFO -  B2G is still running but Marionette can't respond due to either a Gecko, Gaia or Marionette error. Above, the 5 most recent errors are listed. Check logcat for all errors if these errors are not the cause of the failure.
08:00:18    ERROR -  TEST-UNEXPECTED-ERROR | test_visibility.py TestVisibility.testShouldShowElementNotVisibleWhenParentElementHasHiddenAttribute | TimeoutException: TimeoutException: Connection timed out
08:00:18     INFO -  Traceback (most recent call last):
08:00:18     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 199, in run
08:00:18     INFO -      self.tearDown()
08:00:18     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 356, in tearDown
08:00:18     INFO -      (self.filepath.replace('\\', '\\\\'), self.methodName))
08:00:18     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 1199, in execute_script
08:00:18     INFO -      filename=os.path.basename(frame[0]))
08:00:18     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/decorators.py", line 35, in _
08:00:18     INFO -      return func(*args, **kwargs)
08:00:18     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 617, in _send_message
08:00:18     INFO -      "Connection timed out", status=errors.ErrorCodes.TIMEOUT)
08:00:18     INFO -  TEST-INFO expected PASS | took 363212ms
}
Comment hidden (Treeherder Robot)
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.