Download speed is not correct

RESOLVED DUPLICATE of bug 435380

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 435380
3 years ago
3 years ago

People

(Reporter: maurizio, Unassigned)

Tracking

31 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

The download page info cannot handle the speed correctly if the website (usually the file sharing type like uploaded) will send the file in a start stop mode.
FF display the peak rate and few seconds to finish for minutes.... 


Actual results:

If the download go like this: start data/start timer
data at 300k/sec for 250msec.
no data for 500msec.
data at 300k/sec for 250msec. and so on
FF display always data rate 300K while the file will arrive next day...


Expected results:

FF should always display for data rate total time/byte arrived.if no byte are arriving the data rate will go down, now it is fixed so I assume it is calculated only when tehre are data coming.
Too many websites use this bug to make people believe they are downloading at 200/300K while they are ten time slower.
I can make screen shots but one is meaningless, the setup is a bit complicated...
Just make speed=total_time /total data, the timer MUST never be stopped.
thanxs
-m
ps: it was very nice to have the speed also on the small window instead to open the full page download but unfortunately newer version of a program can be worse than the previous one :-(

Updated

3 years ago
Component: Untriaged → Download Manager
Product: Firefox → Toolkit

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 435380
You need to log in before you can comment on or make changes to this bug.