Closed Bug 1050358 Opened 5 years ago Closed 5 years ago

chrome://browser/content/browser.xul : Unable to run script because scripts are blocked internally

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1050360

People

(Reporter: benjamin, Unassigned)

Details

I'm getting the following error reported to the browser error console:

"chrome://browser/content/browser.xul : Unable to run script because scripts are blocked internally."

I do this when I hit control-t to open a new tab.

I have iconic Firefox menu and Tree-style-tab installed. Going to try without them shortly.

The stack of the error is:

*	xul.dll!nsContentUtils::WarnScriptWasIgnored(nsIDocument * aDocument) Line 5104	C++
 	xul.dll!nsContentUtils::MaybeFireNodeRemoved(nsINode * aChild, nsINode * aParent, nsIDocument * aOwnerDoc) Line 3965	C++
 	xul.dll!nsINode::RemoveChild(nsINode & aOldChild, mozilla::ErrorResult & aError) Line 536	C++
 	xul.dll!DeleteNodeTxn::DoTransaction() Line 75	C++
 	xul.dll!nsTransactionManager::BeginTransaction(nsITransaction * aTransaction, nsISupports * aData) Line 786	C++
 	xul.dll!nsTransactionManager::DoTransaction(nsITransaction * aTransaction) Line 81	C++
 	xul.dll!nsEditor::DoTransaction(nsITransaction * aTxn) Line 710	C++
 	xul.dll!nsEditor::DeleteNode(nsINode * aNode) Line 1514	C++
 	xul.dll!nsEditor::DeleteNode(nsIDOMNode * aNode) Line 1498	C++
 	xul.dll!nsTextEditRules::WillInsert(nsISelection * aSelection, bool * aCancel) Line 356	C++
 	xul.dll!nsTextEditRules::WillInsertText(EditAction aAction, mozilla::dom::Selection * aSelection, bool * aCancel, bool * aHandled, const nsAString_internal * inString, nsAString_internal * outString, int aMaxLength) Line 640	C++
 	xul.dll!nsTextEditRules::WillDoAction(mozilla::dom::Selection * aSelection, nsRulesInfo * aInfo, bool * aCancel, bool * aHandled) Line 285	C++
 	xul.dll!nsPlaintextEditor::InsertText(const nsAString_internal & aStringToInsert) Line 738	C++
 	xul.dll!nsTextEditorState::SetValue(const nsAString_internal & aValue, bool aUserInput, bool aSetValueChanged) Line 1962	C++
 	xul.dll!mozilla::dom::HTMLInputElement::SetValueInternal(const nsAString_internal & aValue, bool aUserInput, bool aSetValueChanged) Line 2815	C++
 	xul.dll!mozilla::dom::HTMLInputElement::SetValue(const nsAString_internal & aValue, mozilla::ErrorResult & aRv) Line 1819	C++
 	xul.dll!mozilla::dom::HTMLInputElementBinding::set_value(JSContext * cx, JS::Handle<JSObject *> obj, mozilla::dom::HTMLInputElement * self, JSJitSetterCallArgs args) Line 1930	C++
 	xul.dll!mozilla::dom::GenericBindingSetter(JSContext * cx, unsigned int argc, JS::Value * vp) Line 2418	C++
 	mozjs.dll!js::Invoke(JSContext * cx, JS::CallArgs args, js::MaybeConstruct construct) Line 464	C++

I'm not completely clear on whether this is a bug where the Firefox frontend is doing something it shouldn't be doing, or whether the the DOM code has a bug. Filing in Firefox/untriaged for now. smaug can you provide guidance on where this should live/who should look at it next/whether this is a serious issue?
Flags: needinfo?(bugs)
Well, we certainly shouldn't have any mutation event listeners in FF code.
Flags: needinfo?(bugs)
But looking this some more...
Aha, we may get the warning even if there are no mutation event listeners.

And we have the scriptblocker here
http://hg.mozilla.org/mozilla-central/annotate/aa1617678a90/content/html/content/src/nsTextEditorState.cpp#l1864
and we're dealing with native anonymous content.


The warning is just wrong. We shouldn't warn in case of a native anonymous content.
Blocks: 1042587
Component: Untriaged → DOM
Product: Firefox → Core
This also happens in SeaMonkey on startup from a clean profile

Error: chrome://navigator/content/navigator.xul : Unable to run script because scripts are blocked internally.
OS: Linux → All
Summary: chrome://browser/content/browser.xul : Unable to run script because scripts are currently blocked → chrome://browser/content/browser.xul : Unable to run script because scripts are blocked internally
Duplicate of this bug: 1055802
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1050360
No longer blocks: 1050360
Duplicate of this bug: 1055802
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.