Updates to canvas and DOM elements are not rendered on the same frame

RESOLVED WORKSFORME

Status

()

Core
Canvas: 2D
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: ben, Unassigned)

Tracking

31 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce:

Repeatedly animate both a canvas and some other DOM elements. http://jsfiddle.net/beandog/bekbnpL4/


Actual results:

DOM element updates and canvas updates rendered in different frames, despite both being updated in the same Javascript function


Expected results:

Canvas and DOM updates should be synchronized, as in Chrome/IE11.
(Reporter)

Comment 1

4 years ago
I would love to know a workaround, if any, that would let me continue with my project in the short term while waiting for a fix.

Comment 2

4 years ago
It looks like it's fixed in Aurora (FF33) and Nightly (FF34), so just use Aurora for your project:
https://www.mozilla.org/en-US/firefox/channel/#aurora

It's even faster in Nightly.

Comment 3

4 years ago
Working range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cb9f34f73ebe&tochange=9d8d16695f6a
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.