Closed Bug 105040 Opened 18 years ago Closed 18 years ago

nsStdURL::SetSpec is 1% of startup

Categories

(Core :: Networking, defect, P2)

x86
Windows 2000
defect

Tracking

()

RESOLVED DUPLICATE of bug 103916
mozilla0.9.6

People

(Reporter: dp, Assigned: darin.moz)

References

Details

(Keywords: perf)

nsStdURL::SetSpec  635 calls   30ms

This is dominated by
nsStdURL::Parse 90%    635calls   27ms

The breakdown for nsStdURL::Parse is

Descendent                           %    #    ms
nsStdURLParser::ParseAtDirectory     57  493   16
nsStdURLParser::ParseAtScheme        19  493    5
nsNoAuthURLParser::ParseAtDirectory  15  141    4
nsNoAuthURLParser::ParseAtScheme      6  141    2
PL_strfree                            2  634    1
nsAuthURLParser::ParseAtScheme        0    1    0
nsAuthURLParser::ParseAtDirectory     0    1    0
Blocks: 7251
Keywords: perf
my patch for bug 103916 will include a new URL parser that only returns indices
and lengths instead of malloc'd copies of the individual URL segments.

so, probably this bug should be marked dependent on that one.
Depends on: 103916
working on for 0.9.6
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla0.9.6
while not exactly a dupe of bug 103916, i'm marking it as a dupe because the
patch for bug 103916 will contain the fix for this as well.

*** This bug has been marked as a duplicate of 103916 ***
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.