Context menus are 'Sticky'

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: IDontUseMozillaAnyMore, Assigned: hyatt)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This is an odd little one. I first noticed it in Mail/News but it works equally
oddly in the browser. I've first noticed it in 0.9.5 but have not got an older
version currently installed to try it on. Anyhow, this is the issue. It's
particularly easy to demonstrate in mail/news if you use the 'copy to'
menu for the very first time. The slight delay while the sub menu
is built allows you to perform step 3.

1) Click and hold on a window until the context menu pops up.
2) Keep hold of the mouse and move it down to hilight one of
   the lower menu items.3) Now slide the mouse of to the side of the menu. Sometimes
   the selected menu item will remain 'lit'. It seems to be
   associated with moving the mouse quickly to the side.
4) Now click in the window you started with. The contect menu
   will disapear (as it should).
5) Now click and hold to bring the context menu back up.

What you see:

The context menu that appears the second time has a hilight
on the item you slid off in step 4. It also has the hilight
on the place the mouse is over.

What you should see:

A standard context menu with no extra hilight.

This issue seems to be related to the javascript issue
you can get with web pages that use the mouseOver and
mouseOut events to change 'buttons'. If you move the
mouse away from the image rapidly enough you don't get a
MouseOut event and thus the image stays 'lit'. The context
menu doesn't seem to be getting it's 'Turn off the hilight'
event. The other issue is each time it appears it should
reset any hilight markers.

Comment 1

17 years ago
I can't reproduce this on Mac in a curretn trunk build. But it does have a 
certain resonance with bug 94980'Keyboard navigation in context menu causes 
highlight upon reopening '

Comment 2

17 years ago
WorksForMe using Mac/2001112011.

Ian, can you still reproduce this problem using Mozilla 0.9.6?

Comment 3

17 years ago
Ian Kennedy: Are you still seeing this bug?

Bug 94980 which may have been related, was fixed Dec. 11th. last year

In order to reply: Please use the form on web, link found near top of bugmail.

Comment 4

17 years ago
No reply, ->WFM. Ian re-open this bug if you can still see the
bug in a current build. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.