BluetoothDBusService leaks a LazyIdleThread from a StaticRefPtr

RESOLVED FIXED in 2.1 S2 (15aug)

Status

Firefox OS
Bluetooth
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: khuey, Assigned: jocelyn)

Tracking

({mlk})

unspecified
2.1 S2 (15aug)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink:P2] [p=1])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Updated

4 years ago
Assignee: nobody → joliu
(Assignee)

Comment 1

4 years ago
Created attachment 8469772 [details] [diff] [review]
Bug 1050494: Clear sBluetoothThread in BluetoothDBusService on shutdown to fix memory leak.

* Fixed memory leak caused by sBluetoothThread.

I also checked other parts in BT component that uses StaticAutoPtr/StaticRefPtr, they are all nullout at some point.
This should be the last one.
Thanks, Kyle!

Hi Shawn,
Please help to review this patch.
Thanks.
Attachment #8469772 - Flags: review?(shuang)
(Assignee)

Updated

4 years ago
Whiteboard: [MemShrink:P2] → [MemShrink:P2] [p=1]
Target Milestone: --- → 2.1 S2 (15aug)
Comment on attachment 8469772 [details] [diff] [review]
Bug 1050494: Clear sBluetoothThread in BluetoothDBusService on shutdown to fix memory leak.

Review of attachment 8469772 [details] [diff] [review]:
-----------------------------------------------------------------

r=me
Attachment #8469772 - Flags: review?(shuang) → review+
(Assignee)

Comment 3

4 years ago
Created attachment 8469838 [details] [diff] [review]
[Final] Bug 1050494: Clear sBluetoothThread in BluetoothDBusService on shutdown to fix memory leak. r=shuang

Thanks, Shawn.
Attachment #8469772 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/1eded73d823b
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.