[Camera] HDR indicator remains on screen in video mode, phone enters unusable state, reboot required

RESOLVED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Camera
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: djf, Assigned: dmarcos)

Tracking

({regression})

unspecified
2.1 S3 (29aug)
x86
Mac OS X
regression

Firefox Tracking Flags

(b2g-v2.1 fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
On Flame, in both 2.0 and on master, if I turn on HDR and then switch to video recording the HDR indicator remains on the screen, which seems like the wrong thing. It doesn't actually do anything for videos, does it?

The HDR mode option remains in the menu when in video mode too, but I'm not sure whether that should be considered a bug or not.

The situation is much worse on master than it is in 2.0 however:

1) Launch camera
2) Use settings menu to enable HDR
3) switch to video mode
4) start recording video
5) camera plays the start recording sound but does not display the recording timer. It allows me to touch-focus, but none of the buttons do anything.  If I kill the app, it does not work when I restart it (black viewfinder) an I have to reboot the phone.
(Reporter)

Comment 1

4 years ago
I'm going to go out on a limb and mark this as a 2.1 blocker and a regression.

Needinfo Mike becasue he may be interested in investigating the Gecko issues that cause the camera to become unusable.

Needinfo Diego and Justin because one of them can probably stop this from happening by turning off HDR mode when we switch to video mode.
blocking-b2g: --- → 2.1+
Flags: needinfo?(mhabicher)
Flags: needinfo?(jdarcangelo)
Flags: needinfo?(dmarcos)
Keywords: regression
QA Wanted for branch checks & get a window after the branch checks.
Keywords: qawanted
I just tried reproducing this on Flame/KK:
- gonk:  v162-3
- gecko: master:a7cf4142b4a5c50e95b6929de4141ca55b135d33
- gaia:  master:c97d1b6c3094e854377b6affa5f46b8d4b7316ce

...and although the HDR menu option is there in video mode, and it can be enabled (weird), video recording progresses normally.
Flags: needinfo?(mhabicher)
I just tried to reproduce this on my dogfooding phone, which is loaded with:
- gonk:  v123
- gecko: master:20140808123011
- gaia:  master:88e0a972

...and didn't see the issue.

My phone is a bit of a Frankenstein's monster--I'll try flashing something a little more recent.

Note:

# adb shell cat /proc/meminfo
MemTotal:         186916 kB
Update: using the STR in comment 0, I can reproduce this issue!

What I see is that recording starts fine. While recording, touch-to-focus brings up the focus circle and it spins, but it never turns green and the viewfinder never focuses where I touched. Also, I can stop recording, but once I do, none of the camera UI elements respond except touch-to-focus (which now happens everywhere), which still doesn't do anything.

Killing the Camera app and reopening it brings it back up with a black viewfinder.

Build, running on Flame/512 (to enable HDR):
- gonk:  v123
- gecko: b2g-inboudn:7048b5362ad0
- gaia:  master:1a6282f433f87031e62fe1bf0a79992e8d30ac17 + bug 1051200 patch
Further to comment 5:
- if HDR is off, the issue does not reproduce.
- if HDR is off when switching to video mode, and then enabled while in video mode, the issue does not reproduce.
Update to commen 6:
- if HDR is off when switching to video mode, and then enabled while in video mode, I can start recording, and stop it (like in comment 5); but when I start recording again, the issue does reproduce. Eventually I get a blank alert box:

Camera
------------------


      OK
...and after dismissing the alert box in comment 7, the viewfinder is black. The Camera appears to respond to touches-to-focus, though they never succeed; and tapping the start-recording button brings the alert box back.

Updated

4 years ago
Assignee: nobody → dmarcos
Target Milestone: --- → 2.1 S3 (29aug)
(Assignee)

Comment 9

4 years ago
Created attachment 8473983 [details] [review]
Pull Request

This PR hides the HDR indicator while in video mode so it's not misleading for the user. 

I cannot reproduce the issues described in comment #6 and comment #0. Can you please try again to reproduce again in master? 

The HDR mode enabled should not affect video recording. If we still see those issues we should into the drivers and gecko land to understand what's going on.
Attachment #8473983 - Flags: review?(jdarcangelo)
Flags: needinfo?(mhabicher)
Flags: needinfo?(dmarcos)
Flags: needinfo?(dflanagan)
(Reporter)

Comment 10

4 years ago
Thanks for keeping me in the loop, Diego. Other than the HDR icon, I was never able to reproduce on master, only on 2.0, and I'm surprised that Mike was able to in comment 6.  I fear that this is something we need to fix in 2.0, if it still reproduces there.
Flags: needinfo?(dflanagan)
(Reporter)

Comment 11

4 years ago
I can't reproduce this on master (from Friday) or 2.0 (from today) anymore. On master, I did manage to get the phone into a state where the slider was on the video camera but the shutter button was for still photos, so I could toggle back and forth but could never take videos.  Probably a separate bug, but I'll attach my screenshot...
(Reporter)

Comment 12

4 years ago
Created attachment 8474785 [details]
photo shutter button while the slider is on video mode
(Reporter)

Comment 13

4 years ago
Please ignore comments #11 and #12. Looks like that was fixed in bug 1054963
Comment on attachment 8473983 [details] [review]
Pull Request

LGTM
Attachment #8473983 - Flags: review?(jdarcangelo) → review+
Flags: needinfo?(jdarcangelo)
(Assignee)

Comment 16

4 years ago
The landed PR only hides the HDR indicator when switching to video mode.
(In reply to Diego Marcos [:dmarcos] from comment #9)

> The HDR mode enabled should not affect video recording. If we still see
> those issues we should into the drivers and gecko land to understand what's
> going on.

I don't see the bad behaviour in comment 0 anymore with HDR on. But I do notice that HDR on does very much seem to affect video recording. Compared to normal (HDR off), a video recorded with HDR on is over-exposed and colours look washed out.
Flags: needinfo?(mhabicher)
Since this has landed and the issue no longer appears, marking RESOLVED FIXED.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-v2.1: --- → fixed
Issue has been resolved, removing some keywords
blocking-b2g: 2.1+ → ---
Keywords: qawanted

Comment 20

4 years ago
This issue has been verified successfully on Flame2.1
Verify video:"verify_1050555.mp4".

Flame2.1 build:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141201001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141201.034405
FW-Date         Mon Dec  1 03:44:15 EST 2014
Bootloader      L1TC00011880

Comment 21

4 years ago
Created attachment 8531165 [details]
Verified video: verify_1050555.mp4.MP4
You need to log in before you can comment on or make changes to this bug.