Closed Bug 1050560 Opened 5 years ago Closed 5 years ago

JS shell build broken with Intl API turned on

Categories

(Firefox Build System :: General, defect, critical)

x86_64
Linux
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED
mozilla34

People

(Reporter: Waldo, Assigned: glandium)

References

Details

(Whiteboard: [fuzzblocker])

Attachments

(1 file)

It looks like https://hg.mozilla.org/mozilla-central/rev/6b285759568c broke building JS with Intl enabled:

...
libjs_static.a
libmozjs-34a1.so
libjs_static.a.desc
Executing: ccache clang++-tip -fno-integrated-as -Qunused-arguments -Qunused-arguments -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Werror=int-to-pointer-cast -Wtype-limits -Wempty-body -Werror=conversion-null -Wsign-compare -Wno-invalid-offsetof -Wno-c++0x-extensions -Wno-extended-offsetof -Wno-unknown-warning-option -Wno-return-type-c-linkage -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe -DDEBUG -DTRACING -g -fno-omit-frame-pointer -fPIC -shared -Wl,-z,defs -Wl,-h,libmozjs-34a1.so -o libmozjs-34a1.so /home/jwalden/moz/slots/js/src/dbg/js/src/tmp5wG3xX.list -lpthread -Wl,-z,noexecstack -Wl,-z,text -Wl,--build-id -B ../../build/unix/gold -Wl,-version-script,symverscript -Wl,-rpath-link,../../dist/bin -Wl,-rpath-link,/usr/local/lib ../../intl/icu/target/lib/libicudata.a ../../intl/icu/target/lib/libicui18n.a ../../intl/icu/target/lib/libicuuc.a -lm -ldl -L/usr/lib64 -lplds4 -lplc4 -lnspr4 -lz -lm -ldl
/home/jwalden/moz/slots/js/src/dbg/js/src/tmp5wG3xX.list:
    INPUT("RegExp.o")
    INPUT("Parser.o")
    INPUT("jsarray.o")
    INPUT("jsatom.o")
    INPUT("jsmath.o")
    INPUT("jsutil.o")
    INPUT("ExecutableAllocatorPosix.o")
    INPUT("MacroAssemblerX86Common.o")
    INPUT("pm_linux.o")
    INPUT("Unified_cpp_js_src0.o")
    INPUT("Unified_cpp_js_src1.o")
    INPUT("Unified_cpp_js_src2.o")
    INPUT("Unified_cpp_js_src3.o")
    INPUT("Unified_cpp_js_src4.o")
    INPUT("Unified_cpp_js_src5.o")
    INPUT("Unified_cpp_js_src6.o")
    INPUT("Unified_cpp_js_src7.o")
    INPUT("Unified_cpp_js_src8.o")
    INPUT("Unified_cpp_js_src9.o")
    INPUT("Unified_cpp_js_src10.o")
    INPUT("Unified_cpp_js_src11.o")
    INPUT("../../mfbt/Compression.o")
    INPUT("../../mfbt/Decimal.o")
    INPUT("../../mfbt/Unified_cpp_mfbt0.o")

/home/jwalden/moz/slots/intl/icu/source/common/udata.cpp:669: error: undefined reference to 'icudt52_dat'
/home/jwalden/moz/slots/intl/icu/source/common/udata.cpp:669: error: undefined reference to 'icudt52_dat'
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[3]: *** [libmozjs-34a1.so] Error 1
make[3]: *** Waiting for unfinished jobs....
make[2]: *** [js/src/target] Error 2
make[1]: *** [compile] Error 2
make: *** [default] Error 2

The relevant build command, running inside js/src, is:

rm -rf dbg && autoconf-2.13 && mkdir dbg && cd dbg && CXX='ccache clang++-tip -fno-integrated-as' CC='ccache clang-tip -fno-integrated-as' ../configure --enable-debug --disable-optimize --enable-valgrind --with-system-nspr && cd .. && make -s -C dbg -j8

so relatively pedestrian, but for it being a standalone build.
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Duplicate of this bug: 1050714
Attachment #8469697 - Flags: review?(mshal) → review+
Whiteboard: [fuzzblocker]
https://hg.mozilla.org/mozilla-central/rev/e498b157651e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
QA Whiteboard: [qa-]
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.