[UX] Visually distinguish "Always Activate" and "Ask to Activate" plugins in Add-on Manager (like "Never Activate")

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
3 years ago
4 months ago

People

(Reporter: cpeterson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I was confused by bug 847244's change to sort about:addon's list of plugins by "Always Activate" and "Ask to Activate" because there is no visual distinction those two states (like there is for "Never Activate" plugins or disabled add-ons).

I thought this was a sorting regression and bisected Nightly builds until I found this was a feature introduced in bug 847244. :)

Perhaps we can we visually distinguish the "Ask to Activate" plugins. Blair suggested we could use grey stripes because we use stripes to indicate a couple of things already.
Flags: needinfo?(shorlander)
(Reporter)

Updated

3 years ago
Summary: [UX] Visual distinguish "Always Activate" and "Ask to Activate" plugins in Add-on Manager → [UX] Visually distinguish "Always Activate" and "Ask to Activate" plugins in Add-on Manager (like "Never Activate")
Markus might have some thoughts here. Or can redirect.
Flags: needinfo?(shorlander) → needinfo?(mjaritz)
By now the plug-in section is mostly to surface flash and DRM plug-in, which makes for a very short list. I do not think we need to improve sorting of that short list that many users will probably (hopefully) never see.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Flags: needinfo?(mjaritz)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.