Login with persona is not working every time

RESOLVED WONTFIX

Status

Cloud Services
Server: Identity
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: viorela, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Sometimes I'm unable login with persona. After adding username/password and tapping Sign in, the login is not successfully done and homepage is returned instead. 

#STR:
1. Go to: https://mozillians.allizom.org
2. Tap Sign in button
3. Add your persona credentials and tap Sign in

#Expected results:
The user is signed in; user's details are displayed on the page.

#Actual results: 
The user is not signed in; homepage is displayed, with Sign in button available.

This is happening also for https://affiliates.allizom.org.
See videos attached.
(Reporter)

Comment 1

3 years ago
Created attachment 8469889 [details]
login_failure_mozillians.webm
(Reporter)

Comment 2

3 years ago
Created attachment 8469890 [details]
login_failure_affiliates.webm
I've filed bug 1050787 and bug 1050781 to add better visual indications to Affiliates and Mozillians as to when login fails or when it's taking too long. It's not really a fix for this necessarily, but it will make the user experience way smoother in these cases.

As for what the issue is, without being able to consistently replicate this, I can only guess, but I suspect this issue is with Affiliates and Mozillians not handling the assertion in a timely manner, rather than an issue with Persona getting the assertion to us in the first place.
The Persona issue tracker is at https://github.com/mozilla/persona/issues

Persona is shutting down so I believe this is WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Component: Identity → Server: Identity
Product: Core → Cloud Services
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.