Reduce overpaint of the email ap

REOPENED
Assigned to

Status

Firefox OS
Gaia::E-Mail
REOPENED
3 years ago
3 years ago

People

(Reporter: vingtetun, Assigned: jrburke)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8469953 [details] [diff] [review]
email.patch

James, this shape some of the overpaint of the app and should result into a few fps win on the main list as well as less memory allocated for it by default.
This should also not break any transitions.
Attachment #8469953 - Flags: review?(jrburke)
(In reply to Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) from comment #0)
> This should also not break any transitions.

Can you clarify if this determination is made by code inspection or if it was on-device testing, and if so, which devices?  (Also whether frame trees were consulted, etc.)
Flags: needinfo?(21)
(In reply to Andrew Sutherland [:asuth] from comment #1)
> (In reply to Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails,
> needinfo? please) from comment #0)
> > This should also not break any transitions.
> 
> Can you clarify if this determination is made by code inspection or if it
> was on-device testing, and if so, which devices?  (Also whether frame trees
> were consulted, etc.)

It was testing on the flame. Let me know if you see any broken animations.
Flags: needinfo?(21)
(Assignee)

Comment 3

3 years ago
Comment on attachment 8469953 [details] [diff] [review]
email.patch

Review of attachment 8469953 [details] [diff] [review]:
-----------------------------------------------------------------

I tried on Flame, using pvt build and latest gaia master as of the writing of this note. Showed FPS and overpaint on device. Overpaint in general seemed to go down by 100-ish, and a few more fps were gained.

Main test was going from message_list to message_reader and back. Numbers are from going back to message list from the message reader, as it was a fairly reliable thing to capture: both card contents were static at that point.

Before: 
fps: 15-18
overpaint: 488


After:
fps:22
overpain: 393

Similar rough diffs for other cards.

I also converted the translateY(0) to none and saw similar gains, the overpaint changes were the most noticeable difference.

:vingtetun, if it helps, I can formalize this as a pull request and merge. If I do not hear anything, that is what I will do on Wednesday Aug 13.

::: apps/email/style/common.css
@@ -60,4 @@
>  }
>  
>  .card.center.anim-vertical {
>    transform: translateY(0);

I also switched this to transform: none in my local test, seemed to have similar benefits for the menu/folder drawer.
Attachment #8469953 - Flags: review?(jrburke) → review+
(In reply to James Burke [:jrburke] from comment #3)
> :vingtetun, if it helps, I can formalize this as a pull request and merge.
> If I do not hear anything, that is what I will do on Wednesday Aug 13.


Please do. I'm on PTO :)
(Assignee)

Comment 5

3 years ago
Sorry for the delay, I was stuck on a refactor branch.

Merged in master:
https://github.com/mozilla-b2g/gaia/commit/f695792496326679702a0b2f48a9c384fd47473a

from pull request:
https://github.com/mozilla-b2g/gaia/pull/22899
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Depends on: 1063311
(Assignee)

Comment 6

3 years ago
As documented in bug 1063311, this change caused some weird layer changes for an activity+cancel flow. Not entirely sure about the root cause, will keep this bug open to track it down, then reapply this change once the root issue is discovered.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

3 years ago
Target Milestone: --- → 2.1 S5 (26sep)
(Assignee)

Updated

3 years ago
Assignee: nobody → jrburke
Target Milestone: 2.1 S5 (26sep) → 2.1 S6 (10oct)
(Assignee)

Updated

3 years ago
Target Milestone: 2.1 S6 (10oct) → ---
You need to log in before you can comment on or make changes to this bug.