Closed Bug 1050812 Opened 8 years ago Closed 5 years ago

Consider adding a CSS property to disable overscroll/snapback

Categories

(Core :: Panning and Zooming, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 951793

People

(Reporter: kats, Unassigned)

References

()

Details

(Keywords: feature, Whiteboard: gfx-noted)

Now that we have overscrolling on Firefox OS we're finding a few places where it's kind of undesirable. Bug 1050789 describes one scenario. It might be worth having a CSS property to disable this behavior. I'm not aware of any property that already does this and a quick search didn't turn up anything either.
This would be much appreciated :)
Sounds right to me.
Whiteboard: gfx-noted
OS: Gonk (Firefox OS) → Mac OS X
Note that bug 951793 is similar.
See Also: → 951793
This is currently being discussion as scroll-boundary-behavior under the WICG:
https://github.com/WICG/scroll-boundary-behavior/issues

All discussion is welcome in this repo. I'll start a spec draft in the repo after a bit more discussion (or lack of) has happened.
This will be handled by 'scroll-boundary-behavior'.

(It looks like the other spec mentioned in this bug [1] has been abandoned [2] in favour of 'scroll-boundary-behavior'.)

[1] https://wicg.github.io/user-gesture-nav/
[2] https://github.com/WICG/user-gesture-nav/issues/2#issuecomment-299188019
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 951793
You need to log in before you can comment on or make changes to this bug.