Closed Bug 1050814 Opened 5 years ago Closed 5 years ago

incorrect duration reported on youtube mp4

Categories

(Core :: Audio/Video, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla34

People

(Reporter: rillian, Assigned: ajones)

References

()

Details

Attachments

(2 files)

Playing back non-dash mp4 from youtube, we report a video has a duration 6510615555426.901 seconds. The actual duration is ~131 seconds.

This value shows up in the youtube player as well as our own native controls and video.duration.
Attached image screenshot
Confirmed in latest OSX nightly; turning on media.mediasource.enabled fixes it.
Assignee: nobody → ajones
Variable shadowing is the culprit
Attachment #8474324 - Flags: review?(edwin)
https://hg.mozilla.org/mozilla-central/rev/cdf1cbfe5c49
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
I still get the incorrect video length displayed on youtube. For example: https://www.youtube.com/watch?v=ZgLO2QiA3DE . I'm on OS X Yosemite though. Perhaps it's not supposed to work there yet.
The fix isn't in Nightly yet, but it works in my m-c builds from today. Tested both on 10.8 and 10.10.
Oh, sorry for the false alarm then.
Duplicate of this bug: 1055845
You need to log in before you can comment on or make changes to this bug.