Firefox Accounts Account Creation/Login UI has "{{tos}}" and "{{pn}}" in plaintext if you hit "back" after entering an email address

RESOLVED DUPLICATE of bug 1048994

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 1048994
3 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
STR:
1. In Settings, tap Firefox Accounts
2. Tap "Create account or sign in"
3. Enter any email address (e.g. "a@a") and hit "Next"
4. Tap "Back" button (at bottom-left), to go back to the email-entry screen

ACTUAL RESULTS:
The disclaimer text below the email field changes to say:
> "By proceeding, I agree to the {{tos}} and {{pn}}
> of Firefox cloud services.Terms of ServicePrivacy
> Notice

(and "Terms of ServicePrivacy Notice" are underlined links)

EXPECTED RESULTS:
No {{tos}} {{pn}} placeholder text; presumably the "Terms of ServicePrivacy Notice" links were supposed to be swapped in for the placeholder text.

NOTE: This works correctly on first load; it's only broken when navigating back to this screen.

I'm using this 2.0-based Nightly build for my flame:
http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2014-08-08-00-02-01-mozilla-b2g32_v2_0-flame/
(Reporter)

Comment 1

3 years ago
Created attachment 8470187 [details]
screenshot: initial load (correct)
(Reporter)

Comment 2

3 years ago
Created attachment 8470192 [details]
screenshot after tapping "next" and then "back" (BROKEN)

(Note: I actually took these screenshots during the First Time Experience, but I can reproduce this from the Settings app as well (which is a bit easier to get to), per comment 0's STR.)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1048994
You need to log in before you can comment on or make changes to this bug.