Modify AOL Repack Configuration for Firefox 32

RESOLVED FIXED

Status

Release Engineering
Releases: Custom Builds
P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: brian ellis, Assigned: mconnor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8470290 [details] [diff] [review]
repack_AOL_changes_for_FF32.diff

+++ This bug was initially created as a clone of Bug #1036097 +++

Export file containing patches for AOL, AOL DE and AOL UK partner repacks for Firefox 32.

The changes with this release are just that the toolbar version number has been changed.  This is true for the US, UK and DE toolbars.
Comment on attachment 8470290 [details] [diff] [review]
repack_AOL_changes_for_FF32.diff

Thanks for filing nice and early. Over to mconnor for a review.
Attachment #8470290 - Flags: review?(mconnor)
(Reporter)

Comment 2

3 years ago
Any update on this?
(Assignee)

Comment 3

3 years ago
Comment on attachment 8470290 [details] [diff] [review]
repack_AOL_changes_for_FF32.diff

Brian, this also adds aolToolbarSuggest (which looks fine as an autocomplete impl), but please be detailed in your descriptions in the future.
Attachment #8470290 - Flags: review?(mconnor) → review+
(Assignee)

Updated

3 years ago
Assignee: nobody → mconnor
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 4

3 years ago
https://hg.mozilla.org/build/partner-repacks/rev/3f50edddedef

This missed build1, we'll get builds for AOL in the next day or so.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
We didn't get to the partner repack section of the automation yet, so I moved the tags to include the recent changes (specifically rev 909d9fd9517a). Builds should be out in a few hours.
(Reporter)

Comment 6

3 years ago
Hi - I just tested the builds created yesterday (8/26) http://stage.mozilla.org/pub/mozilla.org/firefox/nightly/32.0-candidates/build1/partner-repacks/ and the toolbar is installed but isn't enabled.  That is I see it listed in add-ons but it isn't visible.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

3 years ago
I can reproduce that as well.  I landed the changes as-is, would you prefer that we back out the existing patch or can you investigate why the toolbar is no longer loading?
(Reporter)

Comment 8

3 years ago
Hi - I want to verify that Mike's question is not directed to us (AOL).  I'm assuming it isn't.
(Assignee)

Comment 9

3 years ago
Brian, the question was actually meant to be directed at you.  The add-on is installed, but broken.  If there's a compatibility issue with the new version of the add-on, I'd assume that's something your side would fix.
(Reporter)

Comment 10

3 years ago
Mike - there shouldn't be a compatibility issue, the xpi installs on the ff32 beta just fine.  I just verified this yesterday.  http://client.web.aol.com/toolbarfiles/Prod/downloads/aol/customfirefox/current/aol_toolbar.xpi is the xpi that is used.
(Assignee)

Comment 11

3 years ago
$ diff -ru repack/ addon/
Only in addon/: bootstrap.js
Only in repack/: components
Only in addon/widgets: flight.zip
Only in addon/widgets: pagescraper.zip
Only in addon/widgets: parser.zip
Only in addon/widgets: ticker.zip

On further investigation, it's clear what's going on (I didn't pick up that the add-on had changed to a boostrap-style add-on).  That bootstrap.js is missing is why nothing is loading.  You'll need to create new diffs adding the missing files and removing /components.
(Reporter)

Comment 12

3 years ago
Created attachment 8480627 [details] [diff] [review]
diff file shows removed components directory
(Reporter)

Comment 13

3 years ago
Created attachment 8480633 [details] [diff] [review]
diff file with bootstrap.js
(Reporter)

Comment 14

3 years ago
Mike - diff files for adding bootstrap.js and removing /components attached.
(Assignee)

Comment 15

3 years ago
Brian, this doesn't have the new widgets, is that intended?  You'll need to use hg export -g to get the binary patches for the zip files
(Reporter)

Comment 16

3 years ago
Created attachment 8480844 [details] [diff] [review]
repack_AOL_changes_for_FF32_widgets.diff
(Reporter)

Comment 17

3 years ago
Mike - the widgets were added back in July and I added a diff file for that back then.  I see that aol_uk and aol_de have the widgets just aol is missing.  It isn't a big deal but it would be good for all three to be the same.  I attached the diff file that has the missing widgets.
(Assignee)

Comment 18

3 years ago
folded into a single commit: https://hg.mozilla.org/build/partner-repacks/rev/a2b6ce84dd93

Filed bug 1060089 to request new builds.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Comment 19

3 years ago
When can we expect an updated build for partner repacks? Testing is needed.

Comment 20

3 years ago
Sorry upon further searching I have found builds. Thank You
You need to log in before you can comment on or make changes to this bug.