saving mail attachment crashes Mozilla

RESOLVED WORKSFORME

Status

MailNews Core
MIME
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Leston Buell, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Every time i try to save a particular e-mail attachment, mozilla crashes. I
right-click on the attachment in the headers section of the e-mail message and
select "Save As..." from the context menu. The file dialog appears, which i
click "Okay", Mozilla crashes. The message in question has multiple attachments.
One of the attachments saves just fine. This also happens when i try "Save All"
instead of "Save As..." 

Here is a QFA incident number: TB36777004X. I'm using Linux build
2001-10-16-06-trunk.

Comment 1

17 years ago
Not a mail database issue - from the stack trace, looks like a mime issue:

nsBinHexDecoder::SetContentType()
nsBinHexDecoder::ProcessNextState()
nsBinHexDecoder::ProcessNextChunk()
nsBinHexDecoder::OnDataAvailable()
nsMimeBaseEmitter::OnFull()
WriteSegments()
Write()
nsMimeBaseEmitter::Write()
mime_output_fn()
MimeOptions_write()
MimeObject_write()
MimeExternalObject_parse_decoded_buffer()
MimeLeaf_parse_buffer()
MimeExternalObject_parse_buffer()
MimeMultipart_parse_child_line()
MimeMultipart_parse_line()
convert_and_send_buffer()
mime_LineBuffer()
MimeObject_parse_buffer()
MimeMessage_parse_line()
convert_and_send_buffer()
mime_LineBuffer()
MimeObject_parse_buffer()
mime_display_stream_write()
nsStreamConverter::OnDataAvailable()
nsMailboxProtocol::ReadMessageResponse()
Assignee: bienvenu → ducarroz
Component: Mail Database → MIME
(Reporter)

Comment 2

17 years ago
Same problem when i try to download the same attachment from Yahoo mail.
Incident nubmer TB36779532.

Comment 3

17 years ago
please attach the message that causes this crash...
(Reporter)

Comment 4

17 years ago
Created attachment 65476 [details]
message source

Here's the message source.

Comment 5

17 years ago
possably dups: bug 117042, bug 119820

Comment 6

16 years ago
worksforme linux trunk 2002040422

please reopen if you can reproduce this in 0.9.9 or even better a recent nightly
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

16 years ago
Works for the reporter now, too. 
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.