Closed Bug 1051147 Opened 7 years ago Closed 7 years ago

Fix wrong handling of overflow areas for table rows

Categories

(Core :: Layout: Tables, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla34
Tracking Status
firefox33 --- unaffected
firefox34 - affected

People

(Reporter: seth, Assigned: seth)

References

Details

Attachments

(1 file)

Bug 789096 introduced an issue with the handling of overflow areas for table rows. We're failing to set the size of |desiredSize| in |nsTableRowFrame::DidResize| correctly, resulting in overflow areas that are too small for table rows that are missing cells. It looks like it was just a typo in part 9; the fix is straightforward.
It's a one line fix.
Attachment #8470396 - Flags: review?(smontagu)
[Tracking Requested - why for this release]:

Looks like this is a regression from https://hg.mozilla.org/mozilla-central/rev/634d33dc9d3e .  This doesn't appear to be on any branches yet, but we should fix it before the next one, since it could lead to repainting bugs.
Attachment #8470396 - Flags: review?(smontagu) → review+
https://hg.mozilla.org/mozilla-central/rev/7c352c875f01
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
You need to log in before you can comment on or make changes to this bug.