Problems with localizing Editor - string under Table->Select & Delete should have own entities in *.dtd files.

VERIFIED INVALID

Status

()

VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: mwawoczny, Assigned: cmanske)

Tracking

({l12y})

Trunk
mozilla0.9.6
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Problems with localizing Editor - strings under Table->Select & Delete should have own entities in *.dtd files. Attached patch.
(Reporter)

Comment 1

17 years ago
Created attachment 53806 [details] [diff] [review]
Patch

Comment 2

17 years ago
Why is it a problem to use the same strings in those two menus?  They are 
intended to be identical.
(Assignee)

Comment 3

17 years ago
I agree with brade -- if the strings are identical, there's no reason to 
duplicate them in the DTD file. What problems are you having?
(Reporter)

Comment 4

17 years ago
Mayby in English but not in Polish.

For example after localizing:
editorOverlay.dtd -> tableCells.label -> Cell(s)
editorOverlay.dtd -> tableTable.label -> Table
to (Polish):
editorOverlay.dtd -> tableCells.label -> Komórka
editorOverlay.dtd -> tableTable.label -> Tabela

I've got in Delete menu (Delete->Table):
Usuñ->Tabela instead of Usuñ->Tabelê

Its grammar error.

And I can't localize Table to Tabelê (then it will be ok in Select & Delete menu) because this string is also used in other menus/labels.

For my own needs I only need one entity for Select & Delete, but don't know if in other languages it will be enough, so I've made patch with entities both to Select and Delete menu.
(Reporter)

Comment 5

17 years ago
Or I'm wrong and this strings are used only in Select & Delete menu?

Comment 6

17 years ago
Kathy or Charles, is this a really problem?
(Assignee)

Comment 7

17 years ago
Not that we know of. We released 6.0, 6.01, and recent mozilla milestones with
the same DTD entries and we heard of no problems localizing those.

Comment 8

17 years ago
I don't see the problems for other languages. 

But if it comes in different localization in Polish, we should separate them. 
Actually it is not a good practice to share the same strings because you never 
know it will work the same way for other languages.

Reassigned to cmanske.
Assignee: rchen → cmanske
(Assignee)

Comment 9

17 years ago
Ok, Marek has explained the grammatical reason why the strings should be 
different. But is there any way this could be changed only in the language(s)
that really need it? Or are we not allowed to make XUL changes during localizing?
It's a shame to have to bloat the UI with duplicate strings just for a few 
localizations, but I'll defer to localization rules, of course.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → mozilla0.9.6

Comment 10

17 years ago
Changed QA contact to ruixu@netscape.com.
Keywords: l12y
QA Contact: teruko → ruixu
(Reporter)

Comment 11

17 years ago
Ehhhmmmm... For Polish localization:
If strings from table menu are used _only_ in Table menu (Select & Delete) then this bug is invalid (don;t know if it is invalid for other languages). In other case - if this strings are used in Table menu (Select & Delete) _and_ in other labels (for example in properties editor) then this bug is valid, and we should check if there are any problems with other languages.
(Assignee)

Comment 12

17 years ago
We only share these strings in the table submenus, they can't be used in any other
context because of the restricted association of DTD files with particular XUL 
files. 
Upon close inspection, the only entity that is shared among multiple menus is 
"tableTable.label", shared between Select and Delete menus, which was the example
given in the original bug report. If that string needs to be duplicated, then 
we only need to add one new string for that case, not all the others in the patch.
Marek: So do we need separate "tableSelectTable.label" and 
"tableDeleteTable.label" strings or not?
(Reporter)

Comment 13

17 years ago
No, if it is used only in select and delete then there is no need to separate tabletable entity. So bug should be now invalid. Sorry for troubles ;)
(Assignee)

Comment 14

17 years ago
Ok, marking invalid as instructed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 15

17 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.