Status

()

Core
Plug-ins
RESOLVED INVALID
16 years ago
10 years ago

People

(Reporter: Jose Garza, Assigned: Arun Ranganathan)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: install newest http://www.adobe.com/products/flashplayer/, URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

At the top center of that page you can find a flash animation. It mostly works
well: Passing the mouse pointer over it changes the imgage shape, the pointer
changes to a hand and a text banner shows up

But when it's clicked nothing happens

I´m using Macromedia Shockwave Flash 5.0 r41. I wonder if the problem is there.

It works in iexplore. $&%$@!! MS

Reproducible: Always
Steps to Reproduce:
1.http://www.greenpeace.org.mx
2.Click one of the color circles on the top of the page
3.

Actual Results:  Nothing

Expected Results:  a web page

I´m not sure about the component I pick
It may be that some internal call to the mozilla engine it´s not working
or can also be a problem in the Netscape version of the Flash/Shockwave plugin
->plugins?
Assignee: pchen → av
Component: XP Apps → Plug-ins
QA Contact: sairuh → shrir

Comment 2

16 years ago
When you click on the eyes, the plugin trys to call Liveconnect but fails. These
two calls are observed:
NPN_GetJavaEnv
NPN_GetJavaPeer

The page also doesn't load for me at all in 4.x so I can't test it there. Does
it load for you? They use an EMBED tag. In fact, it has swLiveConnect=yes as an
attribute.

Arun, I think this is yours. It's another i18n site that uses Flash scripting.
Assignee: av → aruner
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
I think this may be the same problem I am running into at
<http://www.ericsson.com/mobileinternet/codezero/game/index.asp?go=1>. If I try
to login to the game or create (save) a new agent, nothing happens.

I am using Build ID: 2002010203 on Windows 2K.

Is anyone even working on this bug? There hasn't been any activity since the
16th of October.
(Reporter)

Comment 4

16 years ago
I have just tested in linux redhat 7.1, Mozila 0.9.7 and the latest flash plugin
(Shockwave Flash 5.0 r47)

The links are still not running

Cheers, José

Comment 5

16 years ago
I have the same problem. One is here: 'http://www.eportfoliotrack.com'. If you
click on the "pie pieces" it should take you to a new URL. Works fine in IE and
 Netscape 4.x. In Mozilla nothing happens when you click. 

Many sites use Flash to move from URL to URL. It is important that this work. 

Comment 6

16 years ago
page uses liveconnect. Is this one more of those flash scriptability issues?  

Comment 7

16 years ago
WFM w2k 2002032708 build at http://www.eportfoliotrack.com
I can login/create agent at 
http://www.ericsson.com/mobileinternet/codezero/game/index.asp?go=1

Comment 8

16 years ago
the original url still does not work, tho. eportfoliotrack.com works fine.

Comment 9

15 years ago
Confirmed Macromedia Flash will not install under Mozilla, but will under IE on 
the same system.

E.g., try to install Flash at 
http://www.macromedia.com/shockwave/download/download.cgi?
P1_Prod_Version=ShockwaveFlash&P5_Language=English

Using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a) Gecko/20020910 
on Windows XP.

Comment 10

15 years ago
The links do not work when selecting over the eyes but it does work if you
select the area on the right. Inside the plug-in they use FSCommand calls:
i_banner
i_banner
i_texts
FSCommand:click trans

i_banner
i_banner
i_texts
FSCommand:click bio_f

i_banner
i_banner
i_texts
FSCommand:click bio_t

i_banner
i_banner
i_texts
FSCommand:click bio_b

i_banner
i_banner
i_texts
FSCommand:click tox

Comment 11

15 years ago
oh, I forgot to add the location fo rthe swf file so you can go to that directly:
http://www.greenpeace.org.mx/imagenes/flash/tm.swf

Updated

14 years ago
Depends on: 178828

Comment 12

14 years ago
still seen with Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4.1) Gecko/20031008
testing http://www.greenpeace.org.mx
opens http://www.greenpeace.org.mx/php/gp.php

This Frame->Open Frame in New Tab gives: http://www.greenpeace.org.mx/php/tb.php
Javascript Console gives 4 warnings:
Warning: assignment to undeclared variable top_menu
Source File: http://www.greenpeace.org.mx/php/tb.php
Line: 26
Warning: assignment to undeclared variable loaded
Source File: http://www.greenpeace.org.mx/php/tb.php
Line: 27
Warning: assignment to undeclared variable this_loaded
Source File: http://www.greenpeace.org.mx/php/tb.php
Line: 28
Warning: assignment to undeclared variable latent_from
Source File: http://www.greenpeace.org.mx/php/tb.php
Line: 29

<script LANGUAGE=JavaScript>
<!--
top_menu = 0;
loaded = "";
this_loaded =0;
latent_from ="";

function openWindow(name) {	
	//window.open (name+'.php',name, 'scrollbars=no,status=no,width=300,height=300');
	//self.focus();
}

...

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
 codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0"
 ID=top_menu WIDTH=270 HEIGHT=47>

and here could be a endless loop if not using IE:
(I don´t know enough about DOM, Javascript or flashscripting to see an error)

function comeLatentFrom() {
	comeFrom(latent_from);
}

function comeFrom(from) {
	if (this_loaded && top_menu) {
		p_menuObj = InternetExplorer ? top_menu : document.top_menu;
		top_menuObj = InternetExplorer ? top_menu : document.top_menu;
	    	if (from=='energia') top_menuObj.GotoFrame (1);
			else
			if (from=='toxicos') top_menuObj.GotoFrame (2);
			else
			if (from=='biodiv') top_menuObj.GotoFrame (3); 
			else 
			if (from=='ing_gen') top_menuObj.GotoFrame (4); 
			else
			if (from=='principal') top_menuObj.GotoFrame (5); 
			else top_menuObj.GotoFrame (0);  	
	} else {
		latent_from = from;	
		setTimeout("comeLatentFrom()", 1000);	
	} 
}
function openWindow2(name) {	
	window.open (name,"wnd");
}

Comment 13

14 years ago
Tried Flash 7.0 r14 and 6.0 r79 on both Mozilla 1.5 and Firebird 0.7. Many sites
still have Flash links that lead nowhere, though the same plugin works for
Netscape 4.7.

Example page: http://www.homestarrunner.com/

Comment 14

14 years ago
Im using Mozilla 1.5 with Windows 2000 and have the Same Problem with Flash Links.
I tried Flash 6 and Flash 7.

Comment 15

14 years ago
I am having the same problem two of the pages I have had this issue with have been 
http://www.enjoyincubus.com 
and the left side menu for
http://www.eagames.com/official/battlefield/1942/us/home.jsp

I am running XP with Mozilla 1.6 and the flash plugin 7

Comment 16

12 years ago
I don't know if this is the same bug, but on ESPN.com, clicking on any of the images that are flash links in the Spotlight area right below the main image will not take you anywhere.  The text below them, however, will.  Also, the Stop/Start Timer circle doesn't work.

Comment 17

12 years ago
I was seeing this, but installing Flash v9,0,16,0 from http://plugindoc.mozdev.org/windows.html#Flash fixed it for me.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060803 Minefield/3.0a1 ID:2006080304 [cairo]

Comment 18

11 years ago
if you have a flash problem, first install a newer version from http://www.adobe.com/products/flashplayer/

if you still have problem, verify the version installed http://www.adobe.com/products/flash/about/
and file a complete comment (versions, steps, etc) in one of the many other, much newer flash bugs

seems the original greenpeace testcase is gone(changed), so closing INVALID
WFM http://www.eportfoliotrack.com/
Status: NEW → RESOLVED
Last Resolved: 11 years ago
QA Contact: shrir → plugins
Resolution: --- → INVALID
Whiteboard: install newest http://www.adobe.com/products/flashplayer/
You need to log in before you can comment on or make changes to this bug.