"the connection was refused..." dialog is misleading

VERIFIED DUPLICATE of bug 40191

Status

VERIFIED DUPLICATE of bug 40191
17 years ago
14 years ago

People

(Reporter: blandoon, Assigned: mpt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

17 years ago
(Perhaps this should be an enhancement request, but I'm not sure.)

Using build 2001101003 on win32, though this has been the case for as long as I
can remember:

Whenever Mozilla is unable to contact a host - seemingly for ANY reason
whatsoever - the dialog reads "The connection was refused when attempting to
contact (whatever)." The error message ought to be more accurate and
informative, since a refused connection is a separate and distinct error from,
say, a timeout (which is more common). There is already a separate message for a
DNS lookup failure, but other errors, most notably timeouts, show up as
connection refusals.

As a test, find a web server that is active, but timing out for whatever reason,
and type in the URL in Mozilla. Observe that the error message is as above,
versus something along the lines of "Connection timed out" in Communicator 4.x
(IE5.5 doesn't count, since it uses those "friendly HTTP error messages" by
default).
Whiteboard: DUPEME

Updated

17 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 40191 ***

Comment 2

17 years ago
thanks rka
Status: RESOLVED → VERIFIED

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.