Closed Bug 1051521 Opened 7 years ago Closed 7 years ago

Intermittent test_hang_submit.xul | application crashed [@ mozilla::ipc::ProcessLink::OnCloseChannel()] after "Assertion failure: (this == mTransport->set_listener(mExistingListener)), at ipc/glue/MessageLink.cpp:379"

Categories

(Core :: IPC, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla34
Tracking Status
firefox32 --- unaffected
firefox33 --- unaffected
firefox34 --- fixed
firefox-esr24 --- unaffected
firefox-esr31 --- unaffected
b2g-v1.4 --- unaffected
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: RyanVM, Assigned: bent.mozilla)

References

Details

(Keywords: assertion, crash, intermittent-failure)

Attachments

(1 file)

Possible regression from bug 1044322?

https://tbpl.mozilla.org/php/getParsedLog.php?id=45607815&tree=Mozilla-Inbound

Ubuntu VM 12.04 mozilla-inbound debug test mochitest-other on 2014-08-09 09:39:00 PDT for push 37df1d58af4a
slave: tst-linux32-spot-473

09:54:18     INFO -  10146 INFO TEST-START | chrome://mochitests/content/chrome/dom/plugins/test/mochitest/test_hang_submit.xul
09:54:18     INFO -  10147 INFO ++DOMWINDOW == 69 (0x94007650) [pid = 1913] [serial = 2101] [outer = 0xa1ab2650]
09:54:18     INFO -  10148 INFO For application/x-test found plugin libnptest.so
09:54:18     INFO -  10149 INFO DMD[2086] $DMD = '(null)'
09:54:18     INFO -  10150 INFO DMD[2086] DMD is not enabled
09:54:18     INFO -  10151 INFO [2086] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /builds/slave/m-in-lx-d-00000000000000000000/build/xpcom/base/nsTraceRefcnt.cpp, line 148
09:54:18     INFO -  10152 INFO [2086] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /builds/slave/m-in-lx-d-00000000000000000000/build/xpcom/base/nsTraceRefcnt.cpp, line 148
09:54:18     INFO -  10153 INFO [2086] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /builds/slave/m-in-lx-d-00000000000000000000/build/xpcom/base/nsTraceRefcnt.cpp, line 148
09:54:18     INFO -  10154 INFO ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmpfbfUOz.mozrunner/runtests_leaks_plugin_pid2086.log
09:54:18     INFO -  10155 INFO Xlib:  extension "RANDR" missing on display ":0".
09:54:18     INFO -  10156 INFO LoadPlugin() /tmp/tmpfbfUOz.mozrunner/plugins/libnptest.so returned ae6121a0
09:54:18     INFO -  10157 INFO [2086] WARNING: '!compMgr', file /builds/slave/m-in-lx-d-00000000000000000000/build/xpcom/glue/nsComponentManagerUtils.cpp, line 63
09:54:18     INFO -  10158 INFO XPCOM_MEM_BLOAT_LOG: /tmp/tmpfbfUOz.mozrunner/runtests_leaks.log
09:54:18     INFO -  10159 INFO Writing to log: /tmp/tmpfbfUOz.mozrunner/runtests_leaks_plugin_pid2086.log
09:54:20     INFO -  10160 INFO Assertion failure: (this == mTransport->set_listener(mExistingListener)), at /builds/slave/m-in-lx-d-00000000000000000000/build/ipc/glue/MessageLink.cpp:379
09:54:20     INFO -  10161 INFO mozilla::ipc::ProcessLink::OnCloseChannel() [ipc/glue/MessageLink.cpp:379]
09:54:20     INFO -  10162 INFO RunnableMethod<mozilla::ipc::ProcessLink, void (mozilla::ipc::ProcessLink::*)(), Tuple0>::Run() [ipc/chromium/src/base/tuple.h:383]
09:54:20     INFO -  10163 INFO MessageLoop::RunTask(Task*) [ipc/chromium/src/base/message_loop.cc:358]
09:54:20     INFO -  10164 INFO MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const&) [ipc/chromium/src/base/message_loop.cc:368]
09:54:20     INFO -  10165 INFO MessageLoop::DoWork() [ipc/chromium/src/base/message_loop.cc:443]
09:54:20     INFO -  10166 INFO base::MessagePumpLibevent::Run(base::MessagePump::Delegate*) [ipc/chromium/src/base/message_pump_libevent.cc:312]
09:54:20     INFO -  10167 INFO MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:229]
09:54:20     INFO -  10168 INFO MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:504]
09:54:20     INFO -  10169 INFO base::Thread::ThreadMain() [ipc/chromium/src/base/thread.cc:171]
09:54:20     INFO -  10170 INFO ThreadFunc [ipc/chromium/src/base/platform_thread_posix.cc:41]
09:54:20     INFO -  10171 INFO libpthread.so.0 + 0x6d4c
09:54:22     INFO -  TEST-INFO | Main app process: killed by SIGSEGV
09:54:22  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/dom/plugins/test/mochitest/test_hang_submit.xul | application terminated with exit code 11
09:54:22     INFO -  runtests.py | Application ran for: 0:11:37.651564
09:54:22     INFO -  zombiecheck | Reading PID log: /tmp/tmpHTQCa6pidlog
09:54:22     INFO -  ==> process 1913 launched child process 1975
09:54:22     INFO -  ==> process 1913 launched child process 2003
09:54:22     INFO -  ==> process 1913 launched child process 2061
09:54:22     INFO -  ==> process 1913 launched child process 2074
09:54:22     INFO -  ==> process 1913 launched child process 2078
09:54:22     INFO -  ==> process 1913 launched child process 2082
09:54:22     INFO -  ==> process 1913 launched child process 2086
09:54:22     INFO -  zombiecheck | Checking for orphan process with PID: 1975
09:54:22     INFO -  zombiecheck | Checking for orphan process with PID: 2003
09:54:22     INFO -  zombiecheck | Checking for orphan process with PID: 2061
09:54:22     INFO -  zombiecheck | Checking for orphan process with PID: 2074
09:54:22     INFO -  zombiecheck | Checking for orphan process with PID: 2078
09:54:22     INFO -  zombiecheck | Checking for orphan process with PID: 2082
09:54:22     INFO -  zombiecheck | Checking for orphan process with PID: 2086
09:54:36  WARNING -  PROCESS-CRASH | chrome://mochitests/content/chrome/dom/plugins/test/mochitest/test_hang_submit.xul | application crashed [@ mozilla::ipc::ProcessLink::OnCloseChannel()]
09:54:36     INFO -  Crash dump filename: /tmp/tmpfbfUOz.mozrunner/minidumps/60cec1ac-6d0c-032d-68f2d5d5-75623f9e.dmp
09:54:36     INFO -  Operating system: Linux
09:54:36     INFO -                    0.0.0 Linux 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686
09:54:36     INFO -  CPU: x86
09:54:36     INFO -       GenuineIntel family 6 model 62 stepping 4
09:54:36     INFO -       1 CPU
09:54:36     INFO -  Crash reason:  SIGSEGV
09:54:36     INFO -  Crash address: 0x0
09:54:36     INFO -  Thread 3 (crashed)
09:54:36     INFO -   0  libxul.so!mozilla::ipc::ProcessLink::OnCloseChannel() [MessageLink.cpp:37df1d58af4a : 379 + 0x19]
09:54:36     INFO -      eip = 0xb2b966e6   esp = 0xb01ff000   ebp = 0xb01ff028   ebx = 0xb6cd0e74
09:54:36     INFO -      esi = 0x8a7a67a0   edi = 0xb01ff210   eax = 0x00000000   ecx = 0xb758a8ac
09:54:36     INFO -      edx = 0x00000000   efl = 0x00210286
09:54:36     INFO -      Found by: given as instruction pointer in context
09:54:36     INFO -   1  libxul.so!RunnableMethod<mozilla::ipc::ProcessLink, void (mozilla::ipc::ProcessLink::*)(), Tuple0>::Run() [tuple.h:37df1d58af4a : 383 + 0x12]
09:54:36     INFO -      eip = 0xb2b96352   esp = 0xb01ff030   ebp = 0xb01ff048   ebx = 0xb6cd0e74
09:54:36     INFO -      esi = 0x93d93ca0   edi = 0xb01ff210
09:54:36     INFO -      Found by: call frame info
09:54:36     INFO -   2  libxul.so!MessageLoop::RunTask(Task*) [message_loop.cc:37df1d58af4a : 357 + 0x8]
09:54:36     INFO -      eip = 0xb2b7afb8   esp = 0xb01ff050   ebp = 0xb01ff088   ebx = 0xb6cd0e74
09:54:36     INFO -      esi = 0x93d93ca0   edi = 0xb01ff210
09:54:36     INFO -      Found by: call frame info
09:54:36     INFO -   3  libxul.so!MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const&) [message_loop.cc:37df1d58af4a : 365 + 0x9]
09:54:36     INFO -      eip = 0xb2b7c71d   esp = 0xb01ff090   ebp = 0xb01ff0a8   ebx = 0xb6cd0e74
09:54:36     INFO -      esi = 0x968d41e0   edi = 0xb01ff0f0
09:54:36     INFO -      Found by: call frame info
09:54:36     INFO -   4  libxul.so!MessageLoop::DoWork() [message_loop.cc:37df1d58af4a : 443 + 0xb]
09:54:36     INFO -      eip = 0xb2b7c8a8   esp = 0xb01ff0b0   ebp = 0xb01ff0f8   ebx = 0xb6cd0e74
09:54:36     INFO -      esi = 0x968d41e0   edi = 0xb01ff0f0
09:54:36     INFO -      Found by: call frame info
09:54:36     INFO -   5  libxul.so!base::MessagePumpLibevent::Run(base::MessagePump::Delegate*) [message_pump_libevent.cc:37df1d58af4a : 311 + 0x8]
09:54:36     INFO -      eip = 0xb2b6e1e6   esp = 0xb01ff100   ebp = 0xb01ff168   ebx = 0xb6cd0e74
09:54:36     INFO -      esi = 0xb020bbb0   edi = 0xb01ff210
09:54:36     INFO -      Found by: call frame info
09:54:36     INFO -   6  libxul.so!MessageLoop::RunInternal() [message_loop.cc:37df1d58af4a : 229 + 0x8]
09:54:36     INFO -      eip = 0xb2b7b1d4   esp = 0xb01ff170   ebp = 0xb01ff198   ebx = 0xb6cd0e74
09:54:36     INFO -      esi = 0xb01ff210   edi = 0xb01ff210
09:54:36     INFO -      Found by: call frame info
Flags: needinfo?(bent.mozilla)
Attached patch changes.patchSplinter Review
I think the assertion is not quite right since we can race with OnChannelError to reset the listener. The behavior in non-DEBUG builds should be right though.
Assignee: nobody → bent.mozilla
Status: NEW → ASSIGNED
Attachment #8470925 - Flags: review?(benjamin)
Flags: needinfo?(bent.mozilla)
Attachment #8470925 - Flags: review?(benjamin) → review+
We'll want to nominate this for b2g32 as well.
https://hg.mozilla.org/mozilla-central/rev/a663f207d55a
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
No more instances since this landed, time for an uplift nomination :)
I don't know that this should be uplifted... The flags say that that branch is for security changes only now?
Flags: needinfo?(bent.mozilla)
(In reply to ben turner [:bent] (use the needinfo? flag!) from comment #8)
> I don't know that this should be uplifted... The flags say that that branch
> is for security changes only now?

It's because they keep re-using the same message every time they create a new approval flag. Please nominate it. Comment 7 shows that this is indeed hitting b2g32 as well.
Comment on attachment 8470925 [details] [diff] [review]
changes.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: DEBUG-only assertion failures
Testing completed: m-c
Risk to taking this patch (and alternatives if risky): DEBUG-only
String or UUID changes made by this patch: None
Attachment #8470925 - Flags: approval-mozilla-b2g32?
Attachment #8470925 - Flags: approval-mozilla-b2g32? → approval-mozilla-b2g32+
You need to log in before you can comment on or make changes to this bug.