"widget module is deprecated" warnings triggered by privacybadgerfirefox add-on

RESOLVED WONTFIX

Status

Add-on SDK
General
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: George R. Goffe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Start Firefox... get error messages immediately.


Actual results:

(process:4702): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

(process:4711): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

(process:4702): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

(process:4736): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
*** UTM:SVC TimerManager:registerTimer - id: browser-cleanup-thumbnails
console.error: privacybadgerfirefox: 
  DEPRECATED: The widget module is deprecated.  Please consider using the sdk/ui module instead.
Traceback (most recent call last):
  File "resource://gre/modules/Task.jsm", line 298, in TaskImpl_run
    let yielded = aSendResolved ? this._iterator.send(aSendValue)
  File "jar:file:///root/.mozilla/firefox/g843tqza.default/extensions/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D.xpi!/lib/io.js", line 212, in exports.IO.readFromFile/<
    onProgress(data);
  File "jar:file:///root/.mozilla/firefox/g843tqza.default/extensions/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D.xpi!/lib/io.js", line 103, in exports.IO.readFromFile/onProgress
    listener.process(lines[i]);
  File "jar:file:///root/.mozilla/firefox/g843tqza.default/extensions/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D.xpi!/lib/filterStorage.js", line 896, in INIParser.prototype.process
    Utils.yield();
  File "jar:file:///root/.mozilla/firefox/g843tqza.default/extensions/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D.xpi!/lib/utils.js", line 380, in exports.Utils.yield
    while (thread.processNextEvent(false));
  File "resource://gre/modules/Promise-backend.js", line 742, in this.PromiseWalker.walkerLoop
    this.handlers.shift().process();
  File "resource://gre/modules/Promise-backend.js", line 863, in Handler.prototype.process
    nextValue = this.onResolve.call(undefined, nextValue);
  File "jar:file:///root/.mozilla/firefox/g843tqza.default/extensions/%7B1280606b-2510-4fe0-97ef-9b5a22eafe30%7D.xpi!/packages/browserWindowOverlay.js", line 606, in exports.loadBrowserWindow/SessionManagerWindow.onLoadDelayed
    this.onLoad();
  File "jar:file:///root/.mozilla/firefox/g843tqza.default/extensions/%7B1280606b-2510-4fe0-97ef-9b5a22eafe30%7D.xpi!/packages/browserWindowOverlay.js", line 669, in exports.loadBrowserWindow/SessionManagerWindow.onLoad
    gSessionManager.recoverSession(window);
  File "chrome://sessionmanager/content/modules/session_manager.jsm", line 144, in this.gSessionManager.recoverSession
    return Private.recoverSession(aWindow);
  File "chrome://sessionmanager/content/modules/session_manager.jsm", line 1404, in Private.recoverSession
    let session = (PreferenceManager.get("restore_temporary")?Constants.BACKUP_SESSION_FILENAME:((PreferenceManager.get("startup") == 1)?Utils.selectSession(Utils._string("resume_session"), Utils._string("resume_session_ok"), values):
  File "chrome://sessionmanager/content/modules/utils.jsm", line 375, in this.Utils.selectSession
    if (this.prompt(aSessionLabel, aAcceptLabel, values))
  File "chrome://sessionmanager/content/modules/utils.jsm", line 335, in this.Utils.prompt
    params, window);
  File "chrome://sessionmanager/content/modules/utils.jsm", line 203, in this.Utils.openWindow
    return Services.ww.openWindow(aParent || null, aChromeURL, "_blank", aFeatures, aArgument);
  File "resource://gre/modules/Promise-backend.js", line 742, in this.PromiseWalker.walkerLoop
    this.handlers.shift().process();
  File "resource://gre/modules/Promise-backend.js", line 863, in Handler.prototype.process
    nextValue = this.onResolve.call(undefined, nextValue);
  File "resource://gre/modules/commonjs/sdk/addon/runner.js", line 113, in startup/<
    run(options);
  File "resource://gre/modules/commonjs/sdk/addon/runner.js", line 149, in run
    let program = main(options.loader, options.main);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 647, in main
    return loader.load(loader, module).exports;
  File "resource://gre/modules/commonjs/sdk/loader/cuddlefish.js", line 129, in CuddlefishLoader/options<.load
    result = load(loader, module);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 299, in load
    evaluate(sandbox, module.uri);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 262, in evaluate
    : loadSubScript(uri, sandbox, encoding);
  File "resource://jid1-mnnxcxisbpnsxq-at-jetpack/privacybadgerfirefox/lib/main.js", line 8, in null
    const ContentPolicy = require("./contentPolicy");
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 621, in require
    freeze(load(loader, module));
  File "resource://gre/modules/commonjs/sdk/loader/cuddlefish.js", line 129, in CuddlefishLoader/options<.load
    result = load(loader, module);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 299, in load
    evaluate(sandbox, module.uri);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 262, in evaluate
    : loadSubScript(uri, sandbox, encoding);
  File "resource://jid1-mnnxcxisbpnsxq-at-jetpack/privacybadgerfirefox/lib/contentPolicy.js", line 15, in null
    const { settingsMap } = require("./ui");
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 621, in require
    freeze(load(loader, module));
  File "resource://gre/modules/commonjs/sdk/loader/cuddlefish.js", line 129, in CuddlefishLoader/options<.load
    result = load(loader, module);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 299, in load
    evaluate(sandbox, module.uri);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 262, in evaluate
    : loadSubScript(uri, sandbox, encoding);
  File "resource://jid1-mnnxcxisbpnsxq-at-jetpack/privacybadgerfirefox/lib/ui.js", line 10, in null
    const widget = require("sdk/widget");
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 621, in require
    freeze(load(loader, module));
  File "resource://gre/modules/commonjs/sdk/loader/cuddlefish.js", line 129, in CuddlefishLoader/options<.load
    result = load(loader, module);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 299, in load
    evaluate(sandbox, module.uri);
  File "resource://gre/modules/commonjs/toolkit/loader.js", line 262, in evaluate
    : loadSubScript(uri, sandbox, encoding);
  File "resource://gre/modules/commonjs/sdk/widget.js", line 59, in null
    "The widget module is deprecated.  " +
  File "resource://gre/modules/commonjs/sdk/util/deprecate.js", line 18, in deprecateUsage
    let stack = get().slice(2);
*** UTM:SVC TimerManager:notify - notified timerID: browser-cleanup-thumbnails




Expected results:

Most if not all these messages indicate possible problems that need to be addressed.

Comment 1

3 years ago
Does the problem still happen after disabling the privacy-badger-firefox add-on?
Flags: needinfo?(grgoffe)
(Reporter)

Comment 2

3 years ago
Andre,

I'll give that a try and report back.

Thanks for your help,

George...
Flags: needinfo?(grgoffe)

Updated

3 years ago
Flags: needinfo?(grgoffe)
(Reporter)

Comment 3

3 years ago
Andre,

I have disabled the privacy-badger-firefox add-on (from eff.org) and the messages no longer appear. I have opened a bug report on their site. https://github.com/EFForg/privacybadgerfirefox/issues

Thanks for your help with this!

Regards,

George...
Flags: needinfo?(grgoffe)

Comment 4

3 years ago
Ah, thanks (and good to hear that you could isolate it a bit)! 
Any direct link to the bug report itself in the EFForg tracker?
Summary: widget module is deprecated → "widget module is deprecated" warnings triggered by privacybadgerfirefox add-on
(Reporter)

Comment 5

3 years ago
Andre,

Here's the bug I created on the EFF site. I included the above info and a pointer to this bug report as well. I have not heard from EFF yet though.

https://github.com/EFForg/privacybadgerfirefox/issues/195

Thanks for your help,

George...
Component: Untriaged → General
Product: Firefox → Add-on SDK
Version: 31 Branch → unspecified
This is expected, the module will continue to work for now, but will be dropped at some point.

It's better to release a new version of your add-on which uses the newer sdk/ui modules and set the mon version to Fx 28 at least.
Will this work for you?
Flags: needinfo?(grgoffe)
(Reporter)

Comment 8

3 years ago
Erik,

I appreciate your efforts with this bug.

Is this question meant for me? I'm not using the add-on now. Is someone at eff.org going to do something about this? I am looking at their bug tracker and don't see any activity.

Have you been able to contact them?

Regards, and thanks,

George...
Flags: needinfo?(grgoffe)
This "DEPRECATED: The widget module is deprecated.  Please consider using the sdk/ui module instead." message is intended if the widget module is used.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.