Files inside the Mozilla package cannot be viewed on Mac OS X

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
17 years ago
7 years ago

People

(Reporter: jeff, Assigned: jj.enser)

Tracking

Trunk
mozilla0.9.6
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This bug pertains to Mozilla 0.9.5 and probably Mozilla releases in the future.
This is the first build that I noticed is using the OS X packaging system. It
places all the directories and files that make up Mozilla in a package called
"Mozilla". You are suppose to be able to view the contents of the package by
left clicking (ctrl-click whatever) and clicking on "Show Package Contents".
When you do this it opens up a finder window with what appears to be a shaded
out folder with the title "Contents". You cannot open this folder. This is
problematic for people who would like to edit files in their chrome directory or
edit some of their .js files. I might be missing something on how you can find
and edit these files. I couldn't find anything else on bugzilla pertaining to
this issue.

Comment 1

17 years ago
WorksForMe using Fizzilla/2001101516 (0.9.5). I'm able to see inside Contents.
WFM, Mac OS X 10.1.

Comment 3

17 years ago
I was seeing this in earlier 0.9.4 package builds, but this appears to work now
in the latest 0.9.4 package build.
i think there might be an OS bug lingering here. the finder is obviously
confused about something.

Comment 5

17 years ago
Maybe this happens because we build the package on OS 9?
Assignee: asa → jj

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 6

17 years ago
Well, interestingly enough, I see the problem with Mozilla 0.9.5 release on my
10.1 box.
Using the terminal, I can cd into Contents, and all the permissions look good.
I'll have to investigate a bit more to find out what can possibly cause this.

Simon: all daily builds of Mozilla & Netscape get packaged under 9.1 so I don't
think this can be the cause of the problem since they all let you browse inside
their Contents folder
Status: NEW → ASSIGNED

Comment 7

17 years ago
Looks to be a problem with the Finder thinking the contents folder, or some other 
part of the package, is 'busy'.  Log out and then log back in and the problem 
will go away.  Somebody verify that this works for somebody besides me and then 
please close this bug.
(Assignee)

Comment 8

17 years ago
Steve's trick worked for me. After logging out and back in, the Contents folder
became accessible.
However, if I copy the Mozilla folder from the disk image to my hard disk one
more time, the new copy presents the same symptom again.
Relaunching the Finder does not fix the problem.
Let's wait for another day or two to see if this goes away as I am still
polishing the packaging automation.
I also mentioned this problem to Apple and they will follow up with me.
(Reporter)

Comment 9

17 years ago
Logging out then in again is working for me as well. I've tried logging in and 
out a couple times and everytime after the first it works. So it looks like 
this may be just the first time after it was copied from the disk image.
Jeff

Updated

17 years ago
Target Milestone: --- → mozilla0.9.6
(Assignee)

Updated

17 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 10

17 years ago
Considering as a Finder bug, until we can prove this is us.
There is a workaround anyway, that can be documented in our release notes.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.