Closed Bug 1051667 Opened 5 years ago Closed 5 years ago

Intermittent browser_bug295977_autoscroll_overflow.js | application timed out after 330 seconds with no output

Categories

(Core :: General, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla34
Tracking Status
firefox32 --- unaffected
firefox33 --- unaffected
firefox34 --- fixed
firefox-esr24 --- unaffected
firefox-esr31 --- unaffected

People

(Reporter: nigelb, Assigned: martijn.martijn)

References

()

Details

(Keywords: intermittent-failure)

Ubuntu VM 12.04 mozilla-inbound debug test mochitest-browser-chrome-3 on 2014-08-10 15:07:32 PDT for push 5709d54523ef
slave: tst-linux32-spot-601
https://tbpl.mozilla.org/php/getParsedLog.php?id=45633816&tree=Mozilla-Inbound

15:13:56     INFO -  3732 INFO --DOMWINDOW == 39 (0x91aecb40) [pid = 1761] [serial = 744] [outer = (nil)] [url = about:blank]
15:13:56     INFO -  3733 INFO --DOMWINDOW == 38 (0xabf47090) [pid = 1761] [serial = 762] [outer = (nil)] [url = about:blank]
15:13:56     INFO -  3734 INFO --DOMWINDOW == 37 (0xabf47470) [pid = 1761] [serial = 764] [outer = (nil)] [url = about:blank]
15:13:56     INFO -  3735 INFO --DOMWINDOW == 36 (0xabf47850) [pid = 1761] [serial = 766] [outer = (nil)] [url = about:blank]
15:13:56     INFO -  3736 INFO --DOMWINDOW == 35 (0x91aef200) [pid = 1761] [serial = 787] [outer = (nil)] [url = about:blank]
15:13:59     INFO -  3737 INFO ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
15:13:59     INFO -  3738 INFO ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
15:13:59     INFO -  3739 INFO --DOMWINDOW == 34 (0xa238bc20) [pid = 1761] [serial = 758] [outer = (nil)] [url = about:blank]
15:13:59     INFO -  3740 INFO --DOMWINDOW == 33 (0x9ac23b40) [pid = 1761] [serial = 750] [outer = (nil)] [url = about:blank]
15:13:59     INFO -  3741 INFO --DOMWINDOW == 32 (0x9ac24ac0) [pid = 1761] [serial = 751] [outer = (nil)] [url = view-source:data:text/plain,hello+world]
15:13:59     INFO -  3742 INFO --DOMWINDOW == 31 (0xa238a4e0) [pid = 1761] [serial = 752] [outer = (nil)] [url = view-source:data:text/plain,hello+world]
15:13:59     INFO -  3743 INFO --DOMWINDOW == 30 (0x9ac23190) [pid = 1761] [serial = 742] [outer = (nil)] [url = about:blank]
15:13:59     INFO -  3744 INFO --DOMWINDOW == 29 (0xa238b650) [pid = 1761] [serial = 756] [outer = (nil)] [url = view-source:data:text/plain,hello+world]
15:14:00     INFO -  3745 INFO --DOMWINDOW == 28 (0x91af0560) [pid = 1761] [serial = 748] [outer = (nil)] [url = view-source:data:text/plain,hello+world]
15:14:00     INFO -  3746 INFO --DOMWINDOW == 27 (0x91af2c20) [pid = 1761] [serial = 740] [outer = (nil)] [url = view-source:about:mozilla]
15:14:00     INFO -  3747 INFO --DOMWINDOW == 26 (0xabf483f0) [pid = 1761] [serial = 770] [outer = (nil)] [url = about:blank]
15:14:00     INFO -  3748 INFO --DOMWINDOW == 25 (0x91aec380) [pid = 1761] [serial = 773] [outer = (nil)] [url = data:text/html,<html><head><meta%20charset="utf-8"></head><body%20id="i"%20style="overflow-y:%20scroll"><div%20style="height:%202000px"></div>%20%20%20%20%20%20<iframe%20id="iframe"%20style="display:%20none;"></iframe>%20%20%20%20%20%20</body></html>]
15:14:00     INFO -  3749 INFO --DOMWINDOW == 24 (0x91aed300) [pid = 1761] [serial = 776] [outer = (nil)] [url = data:text/html,<html><head><meta%20charset="utf-8"></head><style>html,%20body%20{%20width:%20100%;%20height:%20100%;%20overflow-x:%20hidden;%20overflow-y:%20scroll;%20}</style>%20%20%20%20%20%20<body%20id="j"><div%20style="height:%202000px"></div>%20%20%20%20%20%20<iframe%20id="iframe"%20style="display:%20none;"></iframe>%20%20%20%20%20%20</body></html>]
15:14:00     INFO -  3750 INFO --DOMWINDOW == 23 (0x91aed8d0) [pid = 1761] [serial = 779] [outer = (nil)] [url = data:text/html,<html><head><meta%20charset="utf-8"></head><body><div%20id="k"%20style="height:%20150px;%20%20width:%20200px;%20overflow:%20scroll;%20border:%201px%20solid%20black;"><iframe%20style="height:%20200px;%20width:%20300px;"></iframe></div><div%20id="l"%20style="height:%20150px;%20%20width:%20300px;%20overflow:%20scroll;%20border:%201px%20dashed%20black;"><iframe%20style="height:%20200px;%20width:%20200px;"%20src="data:text/html,<div%20style='border:%205px%20solid%20blue;%20height:%20200%;%20width:%20200%;'></div>"></iframe></div><iframe%20id="m"></iframe><div%20style="height:%20200%;%20border:%205px%20dashed%20black;">filler%20to%20make%20document%20overflow:%20scroll;</div></body></html>]
15:14:00     INFO -  3751 INFO --DOCSHELL 0x9a565000 == 8 [pid = 1761] [id = 300]
15:14:00     INFO -  3752 INFO --DOCSHELL 0x9ef5c800 == 7 [pid = 1761] [id = 295]
15:14:04     INFO -  3753 INFO --DOCSHELL 0x98daf000 == 6 [pid = 1761] [id = 22]
15:14:06     INFO -  3754 INFO --DOMWINDOW == 22 (0x9ac25660) [pid = 1761] [serial = 54] [outer = (nil)] [url = about:newtab]
15:14:06     INFO -  3755 INFO --DOMWINDOW == 21 (0x92202400) [pid = 1761] [serial = 730] [outer = (nil)] [url = chrome://global/content/viewSource.xul]
15:14:06     INFO -  3756 INFO --DOMWINDOW == 20 (0x92197400) [pid = 1761] [serial = 746] [outer = (nil)] [url = chrome://global/content/viewSource.xul]
15:14:06     INFO -  3757 INFO --DOMWINDOW == 19 (0x9aa7cc00) [pid = 1761] [serial = 738] [outer = (nil)] [url = chrome://global/content/viewSource.xul]
15:14:06     INFO -  3758 INFO --DOMWINDOW == 18 (0x921a1c00) [pid = 1761] [serial = 754] [outer = (nil)] [url = chrome://global/content/viewSource.xul]
15:14:06     INFO -  3759 INFO --DOMWINDOW == 17 (0xabf48200) [pid = 1761] [serial = 769] [outer = (nil)] [url = data:text/html,<html><head><meta%20charset="utf-8"></head><body><input%20id="r"%20style="width:%20100px;%20height:%20100px;%20vertical-align:%20top;"><textarea%20id="s"%20style="width:%20100px;%20height:%20100px;%20vertical-align:%20top;"></textarea><div%20style="height:%20200%;%20border:%201px%20solid%20black;"></div></body></html>]
15:14:12     INFO -  3760 INFO --DOCSHELL 0x9acdcc00 == 5 [pid = 1761] [id = 293]
15:14:12     INFO -  3761 INFO --DOCSHELL 0x92979c00 == 4 [pid = 1761] [id = 298]
15:14:12     INFO -  3762 INFO --DOMWINDOW == 16 (0x9ac25e20) [pid = 1761] [serial = 58] [outer = (nil)] [url = about:newtab]
15:14:12     INFO -  3763 INFO --DOMWINDOW == 15 (0x9aa79000) [pid = 1761] [serial = 731] [outer = (nil)] [url = about:blank]
15:14:12     INFO -  3764 INFO --DOMWINDOW == 14 (0x92199000) [pid = 1761] [serial = 747] [outer = (nil)] [url = about:blank]
15:14:12     INFO -  3765 INFO --DOMWINDOW == 13 (0xa2414000) [pid = 1761] [serial = 739] [outer = (nil)] [url = about:blank]
15:14:12     INFO -  3766 INFO --DOMWINDOW == 12 (0x9f8cc800) [pid = 1761] [serial = 755] [outer = (nil)] [url = about:blank]
15:14:12     INFO -  3767 INFO --DOMWINDOW == 11 (0x91aecd30) [pid = 1761] [serial = 791] [outer = (nil)] [url = data:text/html,<html><head><meta%20charset="utf-8"></head><body><input%20id="r"%20style="width:%20100px;%20height:%20100px;%20vertical-align:%20top;"><textarea%20id="s"%20style="width:%20100px;%20height:%20100px;%20vertical-align:%20top;"></textarea><div%20style="height:%20200%;%20border:%201px%20solid%20black;"></div></body></html>]
15:14:12     INFO -  3768 INFO --DOMWINDOW == 10 (0x91aef010) [pid = 1761] [serial = 786] [outer = (nil)] [url = data:text/html,<html><head><meta%20charset="utf-8"></head><body><img%20width="100"%20height="100"%20alt="image%20map"%20usemap="%23planetmap"><map%20name="planetmap">%20%20<area%20id="n"%20shape="rect"%20coords="0,0,100,100"%20href="javascript:void(null)"></map><a%20href="javascript:void(null)"%20id="o"%20style="width:%20100px;%20height:%20100px;%20border:%201px%20solid%20black;%20display:%20inline-block;%20vertical-align:%20top;">link</a><input%20id="p"%20style="width:%20100px;%20height:%20100px;%20vertical-align:%20top;"><textarea%20id="q"%20style="width:%20100px;%20height:%20100px;%20vertical-align:%20top;"></textarea><div%20style="height:%20200%;%20border:%201px%20solid%20black;"></div></body></html>]
15:15:29     INFO -  3769 INFO System JS : WARNING resource://gre/components/nsSearchService.js:4377 - assignment to undeclared variable engine
15:20:59     INFO -  3770 INFO checking window state
15:20:59     INFO -  3771 INFO Console message: [JavaScript Warning: "assignment to undeclared variable engine" {file: "resource://gre/components/nsSearchService.js" line: 4377}]
15:20:59  WARNING -  TEST-UNEXPECTED-TIMEOUT | chrome://mochitests/content/browser/toolkit/content/tests/browser/browser_bug295977_autoscroll_overflow.js | application timed out after 330 seconds with no output
15:20:59     INFO -  Xlib:  extension "RANDR" missing on display ":0".
15:21:00     INFO -  TEST-INFO | screentopng: exit 0
15:21:01     INFO -  TEST-INFO | Main app process: killed by SIGIOT
15:21:01  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/content/tests/browser/browser_bug295977_autoscroll_overflow.js | application terminated with exit code 6
15:21:01     INFO -  runtests.py | Application ran for: 0:11:34.537073
15:21:01     INFO -  zombiecheck | Reading PID log: /tmp/tmpCNRoXGpidlog
15:21:01     INFO -  ==> process 1761 launched child process 1830
15:21:01     INFO -  ==> process 1761 launched child process 1834
15:21:01     INFO -  ==> process 1761 launched child process 1864
15:21:01     INFO -  ==> process 1761 launched child process 1882
15:21:01     INFO -  ==> process 1761 launched child process 1901
15:21:01     INFO -  ==> process 1761 launched child process 1920
15:21:01     INFO -  ==> process 1761 launched child process 1941
15:21:01     INFO -  ==> process 1761 launched child process 1960
15:21:01     INFO -  ==> process 1761 launched child process 1979
15:21:01     INFO -  zombiecheck | Checking for orphan process with PID: 1830
15:21:01     INFO -  zombiecheck | Checking for orphan process with PID: 1834
15:21:01     INFO -  zombiecheck | Checking for orphan process with PID: 1864
15:21:01     INFO -  zombiecheck | Checking for orphan process with PID: 1882
15:21:01     INFO -  zombiecheck | Checking for orphan process with PID: 1901
15:21:01     INFO -  zombiecheck | Checking for orphan process with PID: 1920
15:21:01     INFO -  zombiecheck | Checking for orphan process with PID: 1941
15:21:01     INFO -  zombiecheck | Checking for orphan process with PID: 1960
15:21:01     INFO -  zombiecheck | Checking for orphan process with PID: 1979
15:21:14  WARNING -  PROCESS-CRASH | chrome://mochitests/content/browser/toolkit/content/tests/browser/browser_bug295977_autoscroll_overflow.js | application crashed [@ linux-gate.so + 0x424]
15:21:14     INFO -  Crash dump filename: /tmp/tmp9beecx.mozrunner/minidumps/6ac14119-125a-e754-2cd0471a-548e7074.dmp
15:21:14     INFO -  Operating system: Linux
15:21:14     INFO -                    0.0.0 Linux 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686
15:21:14     INFO -  CPU: x86
15:21:14     INFO -       GenuineIntel family 6 model 62 stepping 4
15:21:14     INFO -       1 CPU
15:21:14     INFO -  Crash reason:  SIGABRT
15:21:14     INFO -  Crash address: 0x6ad
15:21:14     INFO -  Thread 0 (crashed)
15:21:14     INFO -   0  linux-gate.so + 0x424
15:21:14     INFO -      eip = 0xb77db424   esp = 0xbfc96780   ebp = 0xbfc967f8   ebx = 0x9f064200
15:21:14     INFO -      esi = 0x00000000   edi = 0xb7667ff4   eax = 0xfffffffc   ecx = 0x00000008
15:21:14     INFO -      edx = 0xffffffff   efl = 0x00000282
15:21:14     INFO -      Found by: given as instruction pointer in context
15:21:14     INFO -   1  libglib-2.0.so.0.3200.1 + 0x4706d
15:21:14     INFO -      eip = 0xb220d06e   esp = 0xbfc96800   ebp = 0x9f064200
15:21:14     INFO -      Found by: previous frame's frame pointer
15:21:14     INFO -   2  libglib-2.0.so.0.3200.1 + 0xf88ff
15:21:14     INFO -      eip = 0xb22be900   esp = 0xbfc96818   ebp = 0x9f064200
15:21:14     INFO -      Found by: stack scanning
15:21:14     INFO -   3  libglib-2.0.so.0.3200.1 + 0x863cf
15:21:14     INFO -      eip = 0xb224c3d0   esp = 0xbfc96820   ebp = 0x9f064200
15:21:14     INFO -      Found by: stack scanning
15:21:14     INFO -   4  libglib-2.0.so.0.3200.1 + 0x868f5
15:21:14     INFO -      eip = 0xb224c8f6   esp = 0xbfc96828   ebp = 0x9f064200
15:21:14     INFO -      Found by: stack scanning
15:21:14     INFO -   5  libxul.so!nsAppShell::ScheduleNativeEventCallback() [nsAppShell.cpp:5709d54523ef : 151 + 0x4]
15:21:14     INFO -      eip = 0xb3a686a9   esp = 0xbfc96830   ebp = 0x9f064200
15:21:14     INFO -      Found by: stack scanning
15:21:14     INFO -   6  libglib-2.0.so.0.3200.1 + 0xf8593
15:21:14     INFO -      eip = 0xb22be594   esp = 0xbfc96834   ebp = 0x9f064200
15:21:14     INFO -      Found by: stack scanning
15:21:14     INFO -   7  libglib-2.0.so.0.3200.1 + 0x46efa
15:21:14     INFO -      eip = 0xb220cefb   esp = 0xbfc9684c   ebp = 0x9f064200
15:21:14     INFO -      Found by: stack scanning
15:21:14     INFO -   8  libglib-2.0.so.0.3200.1 + 0xf7ff3
15:21:14     INFO -      eip = 0xb22bdff4   esp = 0xbfc96850   ebp = 0x9f064200
15:21:14     INFO -      Found by: stack scanning
15:21:14     INFO -   9  libglib-2.0.so.0.3200.1 + 0x471c0
Martin, can you take a look at this issue since you touched this file last?
Flags: needinfo?(martijn.martijn)
Tweaking the summary slightly - in cases like this, where we've had the process hang, we kill the process in order to generate a stack, on the off-chance it tells us something useful. So the root cause of the failure is the hang, rather than the crash.

It looks like the under-review patch in bug 1049786 might help with this, so adding as a dep.
Depends on: 1049786
Summary: Intermittent browser_bug295977_autoscroll_overflow.js | application timed out after 330 seconds with no output | application terminated with exit code 6 | application crashed [@ linux-gate.so + 0x424] → Intermittent browser_bug295977_autoscroll_overflow.js | application timed out after 330 seconds with no output
I added a patch in bug 1049786. See also bug 1049786, comment 18.
The test is closing the last 2 tabs. What I think is happening with this intermittent failure is that not 2 tabs were opened, but only 1 for example. That means, the active tab gets closed and then you get to see the timeout like you're seeing here.
The patch makes sure to never close the active tab.
Flags: needinfo?(martijn.martijn)
No further failures on any of the branches where the follow-up landed.
Assignee: nobody → martijn.martijn
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
QA Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.