Closed Bug 1051758 Opened 7 years ago Closed 7 years ago

Lockscreen Visual Refresh: "More Notifications" hairline is misaligned

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
2.1 S2 (15aug)

People

(Reporter: mnjul, Assigned: mnjul)

References

Details

(Whiteboard: [p=1])

Attachments

(2 files)

Attached image 2014-08-11-18-28-24.png
When lockscreen has more than 4 notifications (on Flame, without music player widget), the "More notifications" hairline is displaced from the fourth notification's bottom hairline. See attachment. This goes contrary to the implementation of bug 1023500, where the two hairlines should overlap together and visually looks like only one hairline.

This is probably a regression. But I think I will fix it without taking too much time finding the patch that caused this.
Note: Quick look and this was caused by 1045656 with CSS changes.
Attached file Patch (PR @ GitHub)
Hi Amy,

Could you check if the hairlines align/overlap properly with this patch? Thanks a lot!
Attachment #8471328 - Flags: ui-review?(amlee)
Comment on attachment 8471328 [details] [review]
Patch (PR @ GitHub)

Hi, 

Thanks for fixing the hairline alignment!
Attachment #8471328 - Flags: ui-review?(amlee) → ui-review+
Comment on attachment 8471328 [details] [review]
Patch (PR @ GitHub)

Hi Greg, here's a trivial CSS patch for you to review. Thanks!
Attachment #8471328 - Flags: review?(gweng)
Attachment #8471328 - Flags: review?(gweng) → review+
Master: https://github.com/mozilla-b2g/gaia/commit/596d0e063e55409c3ad6aba5803f01b6d55f3d7b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.