Closed Bug 1051794 Opened 6 years ago Closed 6 years ago

CKEditor: Set config.forcePasteAsPlainText to true

Categories

(developer.mozilla.org Graveyard :: Editing, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: fscholz, Unassigned)

References

Details

We have a toolbar button that allows you to insert text converted to plain text.

Given that we do *not* want people using the HTML source mode in the editor, making people do so to paste styled content is a terrible idea. I copy and paste styled content regularly, as do many people, I'm sure.

For example, I copy content from one page to another to get layout.

I also copy content out, paste it into a local document to retain it or work on it, then paste it back.

While I agree that the underlying problem of getting cruft in our content because of pasted content, I don't think disabling styled pastes is the right answer.
There's a PR in for this now:  https://github.com/mozilla/kuma/pull/2648

We can waffle if we want.  Let me know if you guys want to proceed.
Have we figured this out yet?  I'm tempted to close this bug.
> While I agree that the underlying problem of getting cruft in our content
> because of pasted content, I don't think disabling styled pastes is the
> right answer.

I think it this is the truth. We need to solve the cruft problem differently.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Yep. I think a part of the problem is that the different kind of pastes we have are not easily discoverable. I needed several years to discover we have a "past without style" button. 

I filed bug 1076724 for this.
Product: developer.mozilla.org → developer.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.