[BB] drawer.css icon + icons.css don't work togheter

RESOLVED WONTFIX

Status

Firefox OS
General
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: crosbow, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8470981 [details]
gaia-icon-icon.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0 (Beta/Release)
Build ID: 20140807004002

Steps to reproduce:

Take the Building Blocks Demo App and try to use gaia-icons in the top of the drawer (instead of using the text: "done")
e.g. see app.html and change 
<body>
  <section id="index" data-position="current">
    <section data-type="sidebar">
      <header>
        <menu type="toolbar">
          <a href="#">Done</a>
        </menu>

<body>
  <section id="index" data-position="current">
    <section data-type="sidebar">
      <header>
        <menu type="toolbar">
          <a href="#"><span class="gaia-icon icon icon-newadd"></span></a>
        </menu>


Actual results:

drawer.css icon class does not work well togheter with icons.css gaia-icon class.


Expected results:

the icon should have less padding like in the actual drawer demo! but the drawer demo cheats and uses a background-image as icon. why, if we have the icons.css?
Comment on attachment 8480790 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23438

Fred, it seems you're the last one to have touched these files!
Attachment #8480790 - Flags: review?(fabrice) → review?(gasolin)

Comment 3

4 years ago
Comment on attachment 8480790 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23438

@wilson would you like review or just wontfix this since you are doing the migration of building-block to web-components?
Attachment #8480790 - Flags: review?(gasolin) → review?(wilsonpage)
See Also: → bug 1060288
shared/style/icons has been deprecated. This drawer building block will be replaced with <gaia-drawer> web-component in v2.2 - v2.3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
If you wish to use any gaia-icons you should be using the shared/elmements/gaia-icons package. The source is at http://github.com/gaia-components/gaia-icons.
Attachment #8480790 - Flags: review?(wilsonpage)
You need to log in before you can comment on or make changes to this bug.