Closed Bug 1052097 Opened 6 years ago Closed 5 years ago

[B2G][Everything.me] Browser history results do not display icons

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 affected)

RESOLVED DUPLICATE of bug 1059470
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- affected

People

(Reporter: rkunkel, Assigned: chens)

References

Details

(Whiteboard: [systemsfe])

Attachments

(3 files)

Attached image screenshot
Description:
When the user performs a search with the Everything.me bar the launches into a webpage, subsequent searches will display matching browser results without an icon.
  
Repro Steps:
1) Update a Flame device to BuildID: 20140811040202
2) Connect to WiFi or enable Cellular Data
3) Click on the Everything.me
4) Type Twitter and hit enter
5) Return to the results screen
6) Without hitting enter, observe the results screen

Actual:
Browser history results do not display an icon
 
Expected:
Browser history results display an icon user can identify (browser icon?)
 
Environmental Variables:
Device: Flame 2.1 Master
BuildID: 20140811040202
Gaia: 19ed3c9e78eaf234cc08484bde6998ae21552ba5
Gecko: a9b43778f0c2
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/2478/
See attached: screenshot
Issue does not occur on the latest 2.0 Flame using 319MB or 512MB memory settings:

Environmental Variables:
Device: Flame 2.0
BuildID: 20140811000210
Gaia: de28796a8956a48bb98ca67df6a33e0622d642d1
Gecko: 5256345f62bd
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Previous browser search results are not displayed
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
(In reply to Roland Kunkel [:RolandK] from comment #0)
> Created attachment 8471058 [details]
> screenshot
> 
> Description:
> When the user performs a search with the Everything.me bar the launches into
> a webpage, subsequent searches will display matching browser results without
> an icon.
>   
> Repro Steps:
> 1) Update a Flame device to BuildID: 20140811040202
> 2) Connect to WiFi or enable Cellular Data
> 3) Click on the Everything.me
> 4) Type Twitter and hit enter
> 5) Return to the results screen
> 6) Without hitting enter, observe the results screen
> 
> Actual:
> Browser history results do not display an icon
>  
> Expected:
> Browser history results display an icon user can identify (browser icon?)
>  
> Environmental Variables:
> Device: Flame 2.1 Master
> BuildID: 20140811040202
> Gaia: 19ed3c9e78eaf234cc08484bde6998ae21552ba5
> Gecko: a9b43778f0c2
> Version: 34.0a1 (2.1 Master)
> Firmware: V123
> User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
> 
> Repro frequency: 100%
> Link to failed test case: https://moztrap.mozilla.org/manage/case/2478/
> See attached: screenshot

The test case linked above seems to link back to a Video test case, not a search one - can you post the correct one?
Flags: needinfo?(rkunkel)
The testcase is https://moztrap.mozilla.org/manage/case/5856.

Reviewing the testcase we are no longer using this issue to block.
Flags: needinfo?(rkunkel)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Component: Gaia::Everything.me → Gaia::Search
I don't understand what comment 3 means. I would expect that our UX designers would require that icons are present with browser history results.

Can we get more clarity on the blocking triage perspective here?
Flags: needinfo?(pbylenga)
Comment 3 was based upon the proposal for a smoketest blocker instead of release.  Since Marcia is taking System Browser and Rocketbar perhaps she would be the best qa lead for this systems frontend.

Also browser history results weren't returned in 2.0 so I don't think this is a regression.

NI on Marcia to determine blocking triage.
Flags: needinfo?(pbylenga) → needinfo?(mozillamarcia.knous)
Keywords: regression
I haven't located the specs for this yet, but I am assuming that having an icon is desired behavior. Keeping need info on this on me for now to find the answer.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
[Blocking Requested - why for this release]: This is missing functionality. This is happening with browser bookmarks to home screen as well and I will file a separate bug for that.
blocking-b2g: --- → 2.1?
Flags: needinfo?(mozillamarcia.knous)
blocking-b2g: 2.1? → 2.1+
Whiteboard: [systemsfe]
Blocks: rocketbar-mvp
No longer blocks: rocketbar-search-mvp
Attached file WIP
Attachment #8483378 - Flags: feedback?(kgrandon)
Assignee: nobody → shchen
Comment on attachment 8483378 [details] [review]
WIP

Sherman - but why do we not display an icon in the first place? Shouldn't the site have some icon from the favicon or apple touch icon?
Attachment #8483378 - Flags: feedback?(kgrandon)
Flags: needinfo?(shchen)
Target Milestone: --- → 2.1 S4 (12sep)
I was thinking favicon will retrieve by chrome browser, and the patch is only changing the default icon for bookmarks once we don't have it.
Flags: needinfo?(shchen)
Yes, but I want to understand why there is no icon as a part of this bug. I wonder if bug 1059470 could be related?
Yeah it could possibly related to bug 1059470, I have tried another two sites with icons successfully retrieved, this is how I did:

1. navigate to bugzilla.mozilla.org
2. navigate to www.mozilla.org
3. type mozilla and search
4. observe the result, also in the attachment
Any update here?
Taking a look at this, the issue is that google search results do not have an icon, that is because they do not specify an icon in their source and rely on the fallback to origin + 'favicon.ico'. That is slated to be fixed in https://bugzilla.mozilla.org/show_bug.cgi?id=1059470, will ask Ben about the status of it
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1059470
You need to log in before you can comment on or make changes to this bug.