Debug build of Chatzilla shows no text

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: matt, Assigned: rginda)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Linux 2.4.9 i686, RedHat 6.1, XFree86 4.1.0

Built from CVS tree pulled around Oct 16, 8:30 PM PDT.

When I invoke Chatzilla from a debug build, the view window where
all of the text should appear shows text for a fraction of a second,
then goes all black.  Waving the cursor over the region doesn't
change it to the cross-beam cursor, so it's like there isn't any
text to be selected.  It's been like this for weeks.

Comment 1

17 years ago
WFM with a latest CVS build.  Do you get any errors on the console, or any JS
errors in the JS console?
(Reporter)

Comment 2

17 years ago
The problem is still there with a debug build pulled at around 6:50 PM
PDT, Oct 18.  I get the following JavaScript warnings (though the line
numbers are off, because of attachment 52477 [details] [diff] [review] from bug 103598):

WARNING: waaah!, file nsXULPrototypeDocument.cpp, line 659
JavaScript strict warning: 
chrome://chatzilla/content/lib/js/irc.js line 1197: redeclaration of var ev

JavaScript strict warning: 
chrome://chatzilla/content/static.js line 574: reference to undefined property
client.bundle

WEBSHELL+ = 5
JavaScript strict warning: 
chrome://chatzilla/content/static.js line 202: reference to undefined property
window.arguments

JavaScript strict warning: 
chrome://chatzilla/content/static.js line 202: reference to undefined property
window.arguments

JavaScript strict warning: 
chrome://chatzilla/content/static.js line 547: reference to undefined property
frames[0].initialized

JavaScript strict warning: 
chrome://chatzilla/content/static.js line 547: reference to undefined property
frames[0].initialized
(Assignee)

Comment 3

17 years ago
WFM on my debug build.  Those errors are just strict mode warnings, and won't
cause problems.  Can you try building on a fresh tree?  fresh profile?  Have you
changed the motif to something funky?
(Reporter)

Comment 4

17 years ago
Alright, it works for me now.  I rebuilt on a fresh tree, and also removed
these switched from configuration:

--enable-cpp-rtti
--enable-optimize=-O2
--enable-idlc
--enable-xterm-updates
--enable-trace-malloc=yes

Comment 5

17 years ago
Ok, then resolving as WFM.
I have occasionally had trouble with -O2 causing strange things to happen.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.