[B2G][Gallery] Gallery LMK's If device is locked while app is loading pictures

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: rmead, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-exploratory], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8471244 [details]
Flame2.0logcat.txt

Description: 
If the Gallery app is loading pictures and the phone is locked, when it is unlocked the app is closed.

Prerequisite: 
Have lots of pictures on your phone memory so that 'Gallery' must take time loading the thumbnails.


Repro Steps:
1) Update a Flame to Build ID: 20140811000210
2) Tap the 'Gallery' app.
3) Wait for the pictures to start loading the tap the power button to lock device. 
4) Tap the power button again and unlock the phone. Observe.

Actual:
The app has closed and you are back on home screen.

Expected:
The 'Gallery' app continues to load thumbnails.


Flame 2.0 (319mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140811000210
Gaia: de28796a8956a48bb98ca67df6a33e0622d642d1
Gecko: 5256345f62bd
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Keywords: Gallery, OOM, X-Heavy, lock, sleep


Repro frequency: (100%)
See attached: Logcat, Video - http://youtu.be/WTBn9WkxXHk
(Reporter)

Comment 1

4 years ago
This issue was reproduced on the Flame 2.1 (319mb), Flame 1.4 (319mb), Buri 2.1, Buri 2.0, Buri 1.4

The search icon in the Alphabet Picker column is unresponsive.

Flame 2.1 (319mb)

Environmental Variables:
Device: Flame Master
Build ID: 20140811040202
Gaia: 19ed3c9e78eaf234cc08484bde6998ae21552ba5
Gecko: a9b43778f0c2
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 1.4 (319mb)

Environmental Variables:
Device: Flame 1.4
Build ID: 20140811063003
Gaia: 4a662f6dd831cf6194d7ad3501b1d56ea2964a20
Gecko: c12f198b5e51
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140811013006
Gaia: 19ed3c9e78eaf234cc08484bde6998ae21552ba5
Gecko: a9b43778f0c2
Version: 34.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140811063003
Gaia: 9f94a78eef3a9305140c550c983871a46b0692e7
Gecko: c2636750a6a1
Version: 32.0 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140811000206
Gaia: 4a662f6dd831cf6194d7ad3501b1d56ea2964a20
Gecko: e1b03b2fb92e
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0




The issue did NOT occur on Flame 2.0 (512mb) and Buri 1.3

When the phone was locked/unlocked the gallery app was still running.


Flame 2.0 (512mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140811000210
Gaia: de28796a8956a48bb98ca67df6a33e0622d642d1
Gecko: 5256345f62bd
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Buri 1.3

Environmental Variables:
Device: Buri 1.3
BuildID: 20140811024001
Gaia: 23f55be856cef53c6604a6fe4aeb09061afbc897
Gecko: ac685e277c7c
Version: 28.0 (1.3)
Firmware: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This issue was reproduced on the Flame 2.1 (319mb), Flame 1.4 (319mb), Buri 2.1, Buri 2.0, Buri 1.4

The search icon in the Alphabet Picker column is unresponsive?

Please double check results and correct this.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(rmead)
(Reporter)

Comment 3

4 years ago
My apologies. The line "The search icon in the Alphabet Picker column is unresponsive." should be replaced with "Locking the phone while Gallery app is loading pictures causes it to OOM."
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(rmead) → needinfo?(ktucker)
status-b2g-v1.3: unaffected → ---
Flags: needinfo?(ktucker)
Please double check the logcat. I don't think this is an OOM.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
status-b2g-v1.3: --- → unaffected
Flags: needinfo?(rmead)
status-b2g-v1.3: unaffected → ---
(Reporter)

Comment 5

4 years ago
After reviewing the Logcat and seeing this line:
08-11 15:18:17.222   288   288 E OomLogger: [Kill]: lowmem_shrink: convert oom_adj to oom_score_adj:

I've determined it was a LMK and not an OOM.
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(rmead) → needinfo?(ktucker)
Summary: [B2G][Gallery] Gallery OOM's If device is locked while app is loading pictures → [B2G][Gallery] Gallery LMK's If device is locked while app is loading pictures
This is by design based upon bug 1039943
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.