MSE main thread assertion when seeking

RESOLVED FIXED in mozilla34

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: cajbir, Assigned: cajbir)

Tracking

Trunk
mozilla34
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Fix
8.46 KB, patch
cajbir
: review+
Details | Diff | Splinter Review
(Assignee)

Description

4 years ago
When seeking in an MSE video an assertion occurs about calling MediaSource::ActiveSourceBuffers on a non-main thread. This assertion was added in a recent landing.

Steps to reproduce:

1) Visit http://cd.pn/mse/ytdemo/dash-player.html?url=http://cd.pn/mse/ytdemo/feelings2.mpd
2) When video plays, seek somewhere

Expected result

3) Video seeks

Actual result

4) Firefox crashes with assertion
(Assignee)

Updated

4 years ago
Assignee: nobody → cajbir.bugzilla
(Assignee)

Comment 1

4 years ago
Created attachment 8471304 [details] [diff] [review]
1052239.patch

Iterate through decoders instead of source buffers.
Attachment #8471304 - Flags: review?(kinetik)
Blocks: 1049327
Comment on attachment 8471304 [details] [diff] [review]
1052239.patch

Review of attachment 8471304 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with comments.

Remove SourceBuffer::ContainsTime and SourceBufferList::AllContainsTime since they're no longer used.

::: content/media/mediasource/SubBufferDecoder.cpp
@@ +133,5 @@
> +  nsresult rv = GetBuffered(ranges);
> +  if (NS_FAILED(rv) || ranges->Length() == 0) {
> +    return false;
> +  }
> +  for (uint32_t i = 0; i < ranges->Length(); ++i) {

Use TimeRanges::Find please.
Attachment #8471304 - Flags: review?(kinetik) → review+
(Assignee)

Comment 3

4 years ago
Created attachment 8471318 [details] [diff] [review]
Fix

Address review comments. Carry r+ forward.
Attachment #8471304 - Attachment is obsolete: true
Attachment #8471318 - Flags: review+

Comment 5

4 years ago
https://hg.mozilla.org/mozilla-central/rev/2c8eb8d36d19
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
No longer blocks: 1049327
Depends on: 1049327
You need to log in before you can comment on or make changes to this bug.