Addons related TPS tests are failing when installing a local add-on, because proxy settings prevent access to 127.0.0.1

RESOLVED FIXED

Status

Mozilla QA
Infrastructure
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: cosmin, Assigned: cosmin)

Tracking

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
Created attachment 8471437 [details]
tps_log.txt

We saw this as soon as we start running TPS tests on Mac OSX.
The failure is reproducible, you just have to run any of the TPS addons tests on OSX. I will investigate this and try to bring more info soon.
(Assignee)

Comment 1

3 years ago
This is the line and the condition where we trigger the fail callback:
https://github.com/mozilla/gecko-dev/blob/f312a9df46537f7b3bf420664cba3d17d789cc37/toolkit/mozapps/extensions/AddonRepository.jsm#L1428
(Assignee)

Comment 2

3 years ago
Created attachment 8471492 [details]
tps_debug_log.txt

This is the log with a debug build, please notice the warning before the failure:
>CROSSWEAVE INFO: starting action: Addons__install
>CROSSWEAVE INFO: executing action ADD on addon "unsigned-xpi@tests.mozilla.org"
>[28408] WARNING: Failed to open external DTD: publicId "-//W3C//DTD HTML 4.01//EN" systemId "http://www.w3.org/TR/html4/strict.dtd" base "http://127.0.0.1:4567/addons/api/unsigned-xpi%40tests.mozilla.org.xml" URL "resource://gre/res/dtd/strict.dtd": file /builds/slave/m-cen-osx64-d-0000000000000000/build/parser/htmlparser/src/nsExpatDriver.cpp, line 702
>CROSSWEAVE ERROR: [phase1] Exception caught: Error: AddonRepository search failed (resource://gre/modules/services-sync/addonutils.js:360:11) JS Stack trace: searchFailed@addonutils.js:360:12 < AddonRepo_reportFailure@AddonRepository.jsm:974:5 < this.AddonRepository._beginSearch/<@AddonRepository.jsm:1448:9 < waitForSyncCallback@async.js:102:7 < makeSpinningCallback/callback.wait@async.js:145:32 < install@addons.jsm:99:18 < TPS.HandleAddons@tps.jsm:459:11 < Addons__install@tps.jsm:920:5 < TPS.RunNextTestAction@tps.jsm:595:1 < TPS.RunNextTestAction@tps.jsm:607:5
This is not only for the strict test. All add-on related tests are broken on OS X. Maybe it is related to the machine we run the tests on.
Assignee: nobody → cosmin.malutan
Status: NEW → ASSIGNED
Summary: TPS test failure in test_addon_sanity.js: [phase1] Exception caught: Error: AddonRepository search failed → Addons related TPS tests are failing with "Error: AddonRepository search failed"
(Assignee)

Comment 4

3 years ago
I found what's the issue here, due to proxy settings we can't acces 127.0.0.1 address. You can just open a plain firefox and try to navigate to 127.0.0.1 and you will see it's forbidend. I changed the address in runner and test to localhost and the test passed.
So the only thing we would have to do here is fix the proxy on mac nodes, I checked the /etc/profile and seems to be correct but I guess it might diffrent on puppetized nodes.
Henrik can you point me where should I check the proxy settings on tps-osx-109 node, or can you check it?
Flags: needinfo?(hskupin)
(Assignee)

Comment 5

3 years ago
For the time being I have fixed this tps-osx-109-2 manually, and the next jobs should pass, I retriggered the aborted job.
Oh, that's good to hear. Great find. I was thinking about something like that. I'm currently not sure if this OS X host is actually running Puppet. I doubt that, but will confirm in a bit. Once we are puppetized it should work: http://hg.mozilla.org/qa/puppet/file/48b3f02d5911/manifests/qa-config.pp#l43
Flags: needinfo?(hskupin)
Component: Firefox Sync: Backend → Infrastructure
Product: Mozilla Services → Mozilla QA
Hardware: x86_64 → All
Something is not working with 127.0.0.0/8. So replacing it directly with 127.0.0.1 should be fine. I did this for both OS X hosts. I will restart the box, and if it works we can solve this bug as fixed.
Ok, all is passing fine now on OS X. Thanks Cosmin! I think we can close this bug now.

Cosmin, please open a PR for coversheet to get OS X jobs started by Pulse messages.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Summary: Addons related TPS tests are failing with "Error: AddonRepository search failed" → Addons related TPS tests are failing when installing a local add-on, because proxy settings prevent access to 127.0.0.1
(Assignee)

Comment 9

3 years ago
Done it, issue #47
https://github.com/mozilla/coversheet/issues/47
You need to log in before you can comment on or make changes to this bug.