Closed Bug 1052442 Opened 8 years ago Closed 8 years ago

[sms] We should never close the activity when viewing the message report

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.1 S2 (15aug)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: ankit93040, Assigned: azasypkin)

References

Details

(Keywords: regression, Whiteboard: [g+][LibGLA, Dev, B][sms-sprint-2.1S2])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce:

1. Go to gallery
2. share an image with message
3. send. (remains in the thread)
4. click on the message content -> message report
5. close (X)


Actual results:

goes to gallery


Expected results:

should not go back to gallery
Flags: needinfo?(felash)
Whiteboard: [g+][LibGLA, Dev, B]
Good finding, this is IMO inappropriate and we should fix this in v2.0.

[Blocking Requested - why for this release]: regression
Blocks: 936729
blocking-b2g: --- → 2.0?
Flags: needinfo?(felash)
Keywords: regression
Summary: [sms]share activity is not proper → [sms] We should never close the activity when viewing the message report
Hey Julien,

Here is the quick css-only fix for this issue (that happens to participants panel too btw). Please let me know what do you think about it?

Thanks!
Assignee: nobody → azasypkin
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8472294 - Flags: feedback?(felash)
Functional regression, so blocking+. Please add a new test to your fix to ensure this does not regress in the future. Thanks!
blocking-b2g: 2.0? → 2.0+
Comment on attachment 8472294 [details] [review]
GitHub pull request URL

r=me

Please land this and file a separate bug for the test. Given this is a 2.0 blocker I don't want to wait too much to land this, and we unfortunately have no marionette JS test yet so working on a test can take more time.

But we definitely need to work on a test on master. And we need to resolve this technical debt by fixing bug 961572 because this gives us regressions each time we touch this button.
Attachment #8472294 - Flags: feedback?(felash) → review+
(In reply to Julien Wajsberg [:julienw] from comment #4)
> Comment on attachment 8472294 [details] [review]
> GitHub pull request URL
> 
> r=me
> 
> Please land this and file a separate bug for the test. Given this is a 2.0
> blocker I don't want to wait too much to land this, and we unfortunately
> have no marionette JS test yet so working on a test can take more time.
> 
> But we definitely need to work on a test on master. And we need to resolve
> this technical debt by fixing bug 961572 because this gives us regressions
> each time we touch this button.

Sure, here is the test follow-up bug 1053964. Try is green now, so landed.

Master: https://github.com/mozilla-b2g/gaia/commit/9ea8602824d203b7d128ccc730eaa6a99b0ba555

Thanks!
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [g+][LibGLA, Dev, B] → [g+][LibGLA, Dev, B][sms-sprint-2.1S2]
This issue has been verified successfully on Flame2.0&2.1&2.2
Verify video:"verify_1052442.mp4".
**User Agent:
Flame2.0: Mozilla/5.0(Mobile;rv:32.0) Gecko/32.0 Firefox/32.0
Flame2.1: Mozilla/5.0(Mobile;rv:34.0) Gecko/34.0 Firefox/34.0

Flame2.0 build
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/29222e215db8
Build-ID        20141203000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141203.034550
FW-Date         Wed Dec  3 03:46:01 EST 2014
Bootloader      L1TC00011880

Flame2.1 build:
Gaia-Rev        dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebce587d2194
Build-ID        20141203001205
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141203.034907
FW-Date         Wed Dec  3 03:49:18 EST 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.