config/external/nss/crmf/moz.build breaks nightly's build system

RESOLVED FIXED in mozilla34

Status

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: StMichalke, Assigned: StMichalke)

Tracking

({regression})

34 Branch
mozilla34
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [npotb])

Attachments

(1 attachment)

Assignee

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 2014081215

Steps to reproduce:

I compile Firefox nightly from its sources with "--with-system-nss" set. mozilla-nss is built from its repository (NSS_3_17_BETA2.


Actual results:

The configure script aborts:

<<EOOUT
Reticulating splines...
Traceback (most recent call last):
  File "./config.status", line 977, in <module>
    config_status(**args)
  File "/usr/src/packages/BUILD/mozilla-central/python/mozbuild/mozbuild/config_status.py", line 148, in config_status
    summary = the_backend.consume(definitions)
  File "/usr/src/packages/BUILD/mozilla-central/python/mozbuild/mozbuild/backend/base.py", line 186, in consume
    for obj in objs:
  File "/usr/src/packages/BUILD/mozilla-central/python/mozbuild/mozbuild/frontend/emitter.py", line 132, in emit
    for out in output:
  File "/usr/src/packages/BUILD/mozilla-central/python/mozbuild/mozbuild/frontend/reader.py", line 750, in read_mozbuild
    raise bre
mozbuild.frontend.reader.BuildReaderError: 
==============================
ERROR PROCESSING MOZBUILD FILE
==============================

The error occurred while processing the following file:

    /usr/src/packages/BUILD/mozilla-central/config/external/nss/crmf/moz.build

The error was triggered on line 11 of this file:

    OS_LIBS += '-lcrmf'

An error was encountered as part of executing the file itself. The error appears to be the fault of the script.

The error as reported by Python is:

    ['ValueError: Only lists can be appended to lists.\n']
EOOUT



Expected results:

Nightly should be being built. It is if the attached patch is applied.

Comment 1

5 years ago
As you attached a patch, you need to ask a review from a dev.
I cc'ed glandium.
Component: Untriaged → Build Config
Flags: needinfo?(mh+mozilla)
Product: Firefox → Core
Attachment #8471630 - Flags: review+
Flags: needinfo?(mh+mozilla)
Keywords: checkin-needed
Whiteboard: [npotb]
Duplicate of this bug: 1053554
Blocks: 1047267
Keywords: regression
https://hg.mozilla.org/integration/mozilla-inbound/rev/ab3de312345b
Assignee: nobody → StMichalke
Flags: in-testsuite-
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/ab3de312345b
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
QA Whiteboard: [qa-]

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.