Closed Bug 10527 Opened 21 years ago Closed 21 years ago

Printing frames crashes Apprunner

Categories

(Core :: Printing: Output, defect, P3, critical)

All
Linux
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: cpratt, Assigned: dcone)

References

()

Details

Attachments

(1 file)

Build ID: 1999072608 (M9, non-Necko build)
Platform: Windows NT

To reproduce:
- Load the above URL
- Select File | Print
- OK the Print dialog to begin printing

Result: You crash.

Expected result: You print.

Talkback report at
http://cyclone/reports/incidenttemplate.CFM?reportID=124&style=0&tc=71&cp=2&ck1=
SUser+email+address&cd1=%25bear%40netscape%2Ecom%25&co1=like&bbid=11626473
(looks like a crash in nsWebShell)

Will investigate on Mac OS and Linux.
Summary: Printing crashes Apprunner → [PP] Printing crashes Apprunner
Mac OS doesn't print and doesn't crash; Linux menus are gone in this build.
Marking PP.
OS: Windows NT → Linux
Summary: [PP] Printing crashes Apprunner → Printing crashes Apprunner
Crashes on Linux as well (forgot to notice the Print button - who needs menus?).
phillip is cooking up a stack trace.
Attached file stack trace on linux
that trace was on build 1999-07-26-14, RedHat 5.2
Status: NEW → ASSIGNED
Printing Frames... crashes apprunner.
Summary: Printing crashes Apprunner → Printing frames crashes Apprunner
Hardware: PC → All
Blocks: 11275
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Frames will now print...
dcone, when did you check in the fix?
I checked in the fix last week when I checked in web shell things I did.  There
are crashes left in some pages but I just determined that those were not caused
by the frame printing code.
Status: RESOLVED → VERIFIED
This crash no longer occurs in the Aug 19th build.
You need to log in before you can comment on or make changes to this bug.