[B2G][Flame][Loop] User must select Firefox Account option twice in order to be correctly logged in

VERIFIED FIXED

Status

Firefox OS
Gaia::Loop
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: rpribble, Assigned: borjasalguero)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [mobile app][blocking][patch available][2.0-exploratory], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Description:
When the user initially chooses a either phone number or a Firefox Account to use with the Loop app, they will have to tap the same Firefox Accounts button twice in order for it to correctly sign them in. The button is selected the first time, the user is prompted to enter their account information, the account is accepted and the prompt disappears, and the user is brought back to sit at the first screen where they already selected Firefox Accounts. They must tap Firefox Account again in order to be signed in correctly. This is confusing to the user, as they already made this selection and signed in correctly.

Prerequisites:
1) Have Loop installed on the DUT.

Repro Steps:
1) Update a Flame device to BuildID: 20140811000210
2) Launch Loop
3) Progress through FTU
4) Tap the phone icon
5) Select Firefox Account
6) Sign in to Firefox Account
7) Tap Firefox Account again
  
Actual:
The user must select the same option twice in order to be correctly signed in. This is confusing.
  
Expected: 
The user is signed in after they correctly enter their account information.
  
Environmental Variables:
Device: Flame 2.0
BuildID: 20140811000210
Gaia: de28796a8956a48bb98ca67df6a33e0622d642d1
Gecko: 5256345f62bd
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
  
Notes:
  
Repro frequency: 100%
See attached: Video, logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8471804 [details]
Logcat.txt
(Reporter)

Comment 2

4 years ago
This issue also occurs on the Flame v2.1(319MB), Flame v2.0 (512MB), Buri v2.1, and Buri v2.0.

Device: Flame Master (319MB)
Build ID: 20140812040201
Gaia: e78e62125eb43c3a28cdc047987ba54430694a2f
Gecko: b53c2753ce9a
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (512MB)
BuildID: 20140811000210
Gaia: de28796a8956a48bb98ca67df6a33e0622d642d1
Gecko: 5256345f62bd
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Buri 2.1 Master
BuildID: 20140812073020
Gaia: e78e62125eb43c3a28cdc047987ba54430694a2f
Gecko: ee1ad12a3939
Version: 34.0a1 (2.1 Master)
Firmware: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Device: Buri 2.0
BuildID: 20140812063006
Gaia: 88e774c606520c9ce349b467866e200e8db31af4
Gecko: d37b1bd92b3d
Version: 32.0 (2.0)
Firmware: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

The user must select the same option twice in order to be correctly signed in.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
Flags: needinfo?(ktucker)
Assignee: nobody → ferjmoreno
Assignee: ferjmoreno → nobody
(Reporter)

Comment 3

4 years ago
Loop Version: 609ec57
Blocks: 1036490
Please add mbarone to the cc list for all loop bugs. Also. we need to specify the memory of the device the issue was encountered on.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(rpribble)
(Reporter)

Comment 5

4 years ago
The issue was found on a device that is set to 319MB.
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(rpribble) → needinfo?(ktucker)
Bad user flow here but I don't think it is a blocker.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Updated

4 years ago
Assignee: nobody → borja.bugzilla
(Assignee)

Updated

4 years ago
Assignee: borja.bugzilla → nobody

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Whiteboard: [2.0-exploratory] → [mobile app][blocking]

Updated

4 years ago
Whiteboard: [mobile app][blocking] → [mobile app][blocking][2.0-exploratory]
Whiteboard: [mobile app][blocking][2.0-exploratory] → [mobile app][blocking][patch available][2.0-exploratory]
Status: NEW → ASSIGNED
Assignee: nobody → borja.bugzilla
Massimo, can you confirm if bug 1045568, resolve also this bug?
Flags: needinfo?(mbarone976)
(Assignee)

Comment 8

4 years ago
Closing as WORKSFORME as https://bugzilla.mozilla.org/show_bug.cgi?id=1045568 was landed. Please Massimo, close this one as RESOLVED > FIXED if everything is fine. Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 9

4 years ago
Tested with Loop v 2ee3206 and works fine
Flags: needinfo?(mbarone976)
Resolution: WORKSFORME → FIXED
Duplicate of this bug: 1062142

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.