[B2G][Loop] Call logs and shared links are not account specific

RESOLVED INVALID

Status

Firefox OS
Gaia::Loop
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Jordan de Geus(JordanD), Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-exploratory], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8471808 [details]
logcat_20140812_1250.txt

Description:
Call logs and shared links will be retained if the user signs out of their current account and logs in with a different Firefox account. 

Setup: 
Setup: 
- Install the Loop app on a device from: https://github.com/mozilla-b2g/firefoxos-loop-client


Repro Steps:
1) Update a Flame to 20140812000205
2) Launch app 
3) Make a few calls to another Loop user
4) Navigate to Settings> Logout
5) Close Loop app> Enter Settings> FxA> Logout of account
6) Log into a new Firefox Account
7) Launch Loop app and login using new FxA
8) Observe call log is retained

Actual:
Call logs and shared links are retained regardless of the account signed in.

Expected:
Call logs and shared links are account specific

Environmental Variables:
Device: Flame 2.0
Build ID: 20140812000205
Gaia: 1144cdc3a544f81c9bf71598aba1cb67d6c95a29
Gecko: 6495a7bd61ed
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 3/3
See attached: Logcat and video
http://youtu.be/PprpBOhnIig
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Flame 2.1 (319mb), Flame 2.0 (519mb), Buri 2.1, Buri 2.0

Actual: Call logs and shared links are not account specific, allowing different accounts to view previous account calls

Flame 2.1 (319mb)

Environmental Variables:
Device: Flame Master
Build ID: 20140812040201
Gaia: e78e62125eb43c3a28cdc047987ba54430694a2f
Gecko: b53c2753ce9a
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0 (512mb)

Environmental Variables:
Device: Flame 2.0
Build ID: 20140812000205
Gaia: 1144cdc3a544f81c9bf71598aba1cb67d6c95a29
Gecko: 6495a7bd61ed
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

----------------------------------------------------------------------------------------------------

This issue does not occur on Flame 1.4, or Buri 1.4 as this feature was not available.

Flame 1.4

Environmental Variables:
Device: Flame 1.4
Build ID: 20140812063005
Gaia: ec395d47cee9234ae93d2410d8ef8724dfc5d6cb
Gecko: 5b219153e2f4
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Buri 1.4 

Environmental Variables:
Device: Buri 1.4
BuildID: 20140812063005
Gaia: ec395d47cee9234ae93d2410d8ef8724dfc5d6cb
Gecko: 5b219153e2f4
Version: 30.0 (1.4)
Firmware: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

3 years ago
This issue was found on Flame 2.0(319mb)

Environmental Variables:
Device: Flame 2.0
Build ID: 20140812000205
Gaia: 1144cdc3a544f81c9bf71598aba1cb67d6c95a29
Gecko: 6495a7bd61ed
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
I am unsure if this is by design or not but I don't think the average end user will be using multiple accounts on one phone so not nominating this to block.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 4

3 years ago
This is a feature. I don't know this feature will be changed for the next versions of Loop Client. Then I close this as invalid now and if this feature changes, we'll test it again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.