If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox is unresponsive for 1 minute on a simple HTML file

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
--
major
RESOLVED INCOMPLETE
3 years ago
2 years ago

People

(Reporter: Vincent Lefevre, Unassigned)

Tracking

({perf})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20140818])

(Reporter)

Description

3 years ago
1. Start Firefox in safe mode.
2. Open http://www.cinemapassion.com/lesaffiches/

Firefox is unresponsive for about 1 minute: during this time I can't do any interaction with it, and Firefox takes much CPU time. And if I iconify the window and de-iconify it, the background remains entirely gray.

The Page Info box says:
  Size: 351.06 KB (359,489 bytes)
which is rather surprising since wget downloads a 1.9 MB file. If I save the file from Firefox (just the HTML file), I get the same 1.9 MB file as wget.

It is basically a big <pre>...</pre>. Many small images (4 different ones in the document), but no javascript.

Note: the main issue here is not that Firefox is slow to render the page, but the fact that the UI is completely frozen during this time.

Comment 1

3 years ago
The problem looks same as bug 1044400.
Keywords: perf
(Reporter)

Comment 2

3 years ago
(In reply to [:Aleksej] from comment #1)
> The problem looks same as bug 1044400.

Yes, but note that the summary of bug 1044400 doesn't say that FF is unresponsive, which is the main problem.

Comment 3

3 years ago
[bugday-20140818]
Replicated this on firefox-34.0a1.en-US.linux-x86_64 (17-Aug-2014). The browser did freeze on the third try but after the page was loaded, and CPUs took significant amount of load.
 OS: Ubuntu 14.04
 Hardware: x86_64

Comment 4

3 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140818030205 CSet: 0aaa2d3d15cc goes "Not Responding" with the steps given in comment 0
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Whiteboard: [bugday-20140818]
Version: 31 Branch → Trunk
http://www.cinemapassion.com/lesaffiches/ is inaccessible 

do you have another testcase example??
Flags: needinfo?(vincent-moz)
Whiteboard: [bugday-20140818] → [closeme 2015-10-01][bugday-20140818]
(Reporter)

Comment 6

2 years ago
Indeed, the web page no longer exists (I've looked at the site whether the page moved somewhere else, but this doesn't seem to be the case). I don't have any other testcase.
Flags: needinfo?(vincent-moz)
Thanks for checking
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2015-10-01][bugday-20140818] → [bugday-20140818]
You need to log in before you can comment on or make changes to this bug.