Firefox doesn't ask to stop a script on infinite loops

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: sworddragon2, Unassigned)

Tracking

32 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

738 bytes, application/xhtml+xml
Details
(Reporter)

Description

3 years ago
Created attachment 8472115 [details]
testcase.xhtml

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140801100255

Steps to reproduce:

In the attachments is a testcase. Just open it and click the button to start the infinite loop.


Actual results:

Firefox will never ask to stop the script which causes the browser to be unresponsible until the process is closed.


Expected results:

The dialog to stop the script should appear after a short time.

Comment 1

3 years ago
Check your "dom.max_script_run_time" value in about:config.
If set it to 2 (second), the dialog shown after a short time.

Test on my Win8.1, Fx32 Beta.
Flags: needinfo?(sworddragon2)

Comment 2

3 years ago
A little of supplement, changing its value is to confirm whether it at works.
(Reporter)

Comment 3

3 years ago
The value was set to 0 (I'm assuming this means that scripts are allowed to run infinite). But I'm wondering how the value got changed. The closest I can think is because I have enabled the checkbox "Don't ask me again" on the "Unresponsive script" dialog and then allowed a script to run in the past. But I was assuming that this checkbox is on a per script and per session base (or something similar) and trying to reproduce this shows that enabling the checkbox and allowing a script to run doesn't change dom.max_script_run_time. Well, who knows what changed the value so I'm marking this ticket as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(sworddragon2)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.