Closed Bug 1053136 Opened 6 years ago Closed 6 years ago

[SMS]Moz10n issues in SMS app

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1040271

People

(Reporter: ankit93040, Unassigned)

Details

(Whiteboard: [g+][LibGLA, Dev, B] )

Attachments

(3 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce:

2 instances are there - 
Instance 1:-
  1. Message->New message->send a message
  2. Long Click on the text -> options are shown
  3. Press home button
  4. Settings->Language->change language
  5. Press home button
  6. Go to message (see the attachment 1 [details] [diff] [review])
Instance 2:-
  1. Message->New Message
  2. options -> options are shown
  3. Press home button
  4. Settings->Language->change language
  5. Press home button
  6. Go to message (see the attachment 2 [details] [diff] [review])



Actual results:

Mozl10n is not properly localized


Expected results:

Mozl10n should be properly localized
Flags: needinfo?(felash)
Whiteboard: [g+][LibGLA, Dev, B]
Attached image 1.jpg
Attached image 2.jpg
Component: General → Gaia::SMS
I'm quite sure instance 2 will be fixed by bug 1040271.
Not sure for instance 1.

Can you please try with the patch in bug 1040271?
Flags: needinfo?(felash)
Hi Julien

Both the instances are resolved with these.

uploading the copied patch from https://github.com/mozilla-b2g/gaia/pull/21941/files which resolves this issue.

When is this patch going to land?
Flags: needinfo?(felash)
Attached patch sms_locale_1040271.patch (obsolete) — Splinter Review
Should land soon;
Thanks for testing!
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(felash)
Resolution: --- → DUPLICATE
Duplicate of bug: 1040271
Hi Julienw

If https://bugzilla.mozilla.org/show_bug.cgi?id=1040271#c23 these can't be uplifted, can these issue be resolved by this patch(attached). Modified patch from 1040271 to resolve this issue.

If that can be uplifted then all's well.

Please review the patch if you are not uplifting.

Thanks!
Flags: needinfo?(felash)
Attached patch 12.patchSplinter Review
Attachment #8472792 - Attachment is obsolete: true
I think it should work fine but be careful to fix any test that fails because of these changes.
Flags: needinfo?(felash)
You need to log in before you can comment on or make changes to this bug.