[stage] Cannot update an existing user profile without changing username and display name

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED INVALID
4 years ago
2 years ago

People

(Reporter: RobertC, Unassigned)

Tracking

({regression})

Details

(Whiteboard: [fromAutomation])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8472298 [details]
addons_profile.png

When trying to update an existing user profile without changing the username or display name 2 errors are displayed (see attached screenshot).
This issue can be reproduced with both manual and automated tests. The issue is only reproduced on stage.

STR:
1. got to https://addons.allizom.org/en-US/firefox/
2. login with an existing account
3. click my profile
4. click edit profile
5. click update account

Expected result:
"Profile updated" message should be displayed

Actual result:
Errors are displayed for username and display name

I managed to update the account if I changed the username and display name to something random and the issue from the STR is no longer reproduce, but when I try to change the info back to the original one I get the same errors.

Comment 1

4 years ago
Looks like "test" is one of the blacklisted names on stage which means that the behavior you are seeing is valid.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(In reply to krupa raj[:krupa] from comment #1)
> Looks like "test" is one of the blacklisted names on stage which means that
> the behavior you are seeing is valid.

Thanks, Krupa; is there a reason, though, that the expectations between dev and stage re: blacklisted names is different?

On dev, we're able to use "test" as a substring in both the username and the display name: https://saucelabs.com/jobs/4723056a95fc4932bfc93249cb656bc3
Flags: needinfo?(krupa.mozbugs)
(Reporter)

Comment 3

4 years ago
I updated the display name in the credentials file to amo.account

Comment 4

3 years ago
test was not blacklisted on dev as far as I can tell. Strings which are blacklisted in environments are different.
Flags: needinfo?(krupa.mozbugs)
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.