Intermittent test_oscillatorNodeStart.html | Assertion count 22 is greater than expected range 0-0 assertions. (and several more) ("ASSERTION: Stream write in unexpected state... in AudioStream.cpp, line 757")

RESOLVED DUPLICATE of bug 1050947

Status

()

Core
Web Audio
--
critical
RESOLVED DUPLICATE of bug 1050947
4 years ago
4 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({assertion})

Trunk
x86
Windows 7
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Windows 7 32-bit mozilla-inbound debug test mochitest-1 on 2014-08-13 05:20:24 PDT for push 9a6455a2eb93

slave: t-w732-ix-018

https://tbpl.mozilla.org/php/getParsedLog.php?id=45839432&tree=Mozilla-Inbound

23838 INFO TEST-UNEXPECTED-ERROR | /tests/content/media/webaudio/test/test_oscillatorNodeStart.html | Assertion count 22 is greater than expected range 0-0 assertions.
24660 INFO TEST-UNEXPECTED-ERROR | /tests/content/media/webaudio/test/test_oscillatorTypeChange.html | Assertion count 43 is greater than expected range 0-0 assertions.
26109 INFO TEST-UNEXPECTED-ERROR | /tests/content/media/webaudio/test/test_pannerNode.html | Assertion count 76 is greater than expected range 0-0 assertions.
26760 INFO TEST-UNEXPECTED-ERROR | /tests/content/media/webaudio/test/test_pannerNodeAbove.html | Assertion count 34 is greater than expected range 0-0 assertions.
27411 INFO TEST-UNEXPECTED-ERROR | /tests/content/media/webaudio/test/test_pannerNodeChannelCount.html | Assertion count 34 is greater than expected range 0-0 assertions.
28252 INFO TEST-UNEXPECTED-ERROR | /tests/content/media/webaudio/test/test_pannerNodeHRTFSymmetry.html | Assertion count 44 is greater than expected range 0-0 assertions.
30347 INFO TEST-UNEXPECTED-ERROR | /tests/content/media/webaudio/test/test_pannerNodeTail.html | Assertion count 110 is greater than expected range 0-0 assertions.

{
06:05:24     INFO -  23434 INFO TEST-START | /tests/content/media/webaudio/test/test_oscillatorNodeStart.html
06:05:24     INFO -  23435 INFO ++DOMWINDOW == 23 (0D247000) [pid = 2752] [serial = 4492] [outer = 1775D400]
06:05:24     INFO -  23436 INFO [Parent 2752] ###!!! ASSERTION: Stream write in unexpected state.: 'mState == INITIALIZED || mState == STARTED || mState == RUNNING', file c:\builds\moz2_slave\m-in-w32-d-0000000000000000000\build\content\media\AudioStream.cpp, line 757
06:05:24     INFO -  23437 INFO mozilla::AudioSegment::WriteTo(unsigned __int64,mozilla::AudioStream *,mozilla::AudioMixer *) [content/media/AudioSegment.cpp:218]
06:05:24     INFO -  23438 INFO mozilla::MediaStreamGraphImpl::PlayAudio(mozilla::MediaStream *,__int64,__int64) [content/media/MediaStreamGraph.cpp:1086]
06:05:24     INFO -  23439 INFO mozilla::MediaStreamGraphImpl::RunThread() [content/media/MediaStreamGraph.cpp:1465]
06:05:24     INFO -  23440 INFO mozilla::`anonymous namespace'::MediaStreamGraphInitThreadRunnable::Run() [content/media/MediaStreamGraph.cpp:1605]
06:05:24     INFO -  23441 INFO nsThread::ProcessNextEvent(bool,bool *) [xpcom/threads/nsThread.cpp:770]
06:05:24     INFO -  23442 INFO NS_ProcessNextEvent(nsIThread *,bool) [xpcom/glue/nsThreadUtils.cpp:265]
06:05:24     INFO -  23443 INFO mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate *) [ipc/glue/MessagePump.cpp:326]
06:05:24     INFO -  23444 INFO MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:229]
06:05:24     INFO -  23445 INFO MessageLoop::RunHandler() [ipc/chromium/src/base/message_loop.cc:223]
06:05:24     INFO -  23446 INFO MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:197]
06:05:24     INFO -  23447 INFO nsThread::ThreadFunc(void *) [xpcom/threads/nsThread.cpp:356]
06:05:25     INFO -  23448 INFO _PR_NativeRunThread [nsprpub/pr/src/threads/combined/pruthr.c:397]
06:05:25     INFO -  23449 INFO pr_root [nsprpub/pr/src/md/windows/w95thred.c:90]
06:05:25     INFO -  23450 INFO MSVCR100 + 0x5c6de
06:05:25     INFO -  23451 INFO MSVCR100 + 0x5c788
06:05:25     INFO -  23452 INFO kernel32 + 0x53c45
06:05:25     INFO -  23453 INFO ntdll + 0x637f5
06:05:25     INFO -  23454 INFO ntdll + 0x637c8
06:05:25     INFO -  23455 INFO [Parent 2752] ###!!! ASSERTION: Stream write in unexpected state.: 'mState == INITIALIZED || mState == STARTED || mState == RUNNING', file c:\builds\moz2_slave\m-in-w32-d-0000000000000000000\build\content\media\AudioStream.cpp, line 757
06:05:25     INFO -  23456 INFO mozilla::AudioSegment::WriteTo(unsigned __int64,mozilla::AudioStream *,mozilla::AudioMixer *) [content/media/AudioSegment.cpp:218]
06:05:25     INFO -  23457 INFO mozilla::MediaStreamGraphImpl::PlayAudio(mozilla::MediaStream *,__int64,__int64) [content/media/MediaStreamGraph.cpp:1086]
06:05:25     INFO -  23458 INFO mozilla::MediaStreamGraphImpl::RunThread() [content/media/MediaStreamGraph.cpp:1465]
06:05:25     INFO -  23459 INFO mozilla::`anonymous namespace'::MediaStreamGraphInitThreadRunnable::Run() [content/media/MediaStreamGraph.cpp:1605]
06:05:25     INFO -  23460 INFO nsThread::ProcessNextEvent(bool,bool *) [xpcom/threads/nsThread.cpp:770]
06:05:25     INFO -  23461 INFO NS_ProcessNextEvent(nsIThread *,bool) [xpcom/glue/nsThreadUtils.cpp:265]
06:05:25     INFO -  23462 INFO mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate *) [ipc/glue/MessagePump.cpp:326]
06:05:25     INFO -  23463 INFO MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:229]
06:05:25     INFO -  23464 INFO MessageLoop::RunHandler() [ipc/chromium/src/base/message_loop.cc:223]
06:05:25     INFO -  23465 INFO MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:197]
06:05:25     INFO -  23466 INFO nsThread::ThreadFunc(void *) [xpcom/threads/nsThread.cpp:356]
06:05:25     INFO -  23467 INFO _PR_NativeRunThread [nsprpub/pr/src/threads/combined/pruthr.c:397]
06:05:25     INFO -  23468 INFO pr_root [nsprpub/pr/src/md/windows/w95thred.c:90]
06:05:25     INFO -  23469 INFO MSVCR100 + 0x5c6de
06:05:25     INFO -  23470 INFO MSVCR100 + 0x5c788
06:05:25     INFO -  23471 INFO kernel32 + 0x53c45
06:05:25     INFO -  23472 INFO ntdll + 0x637f5
06:05:25     INFO -  23473 INFO ntdll + 0x637c8
...
}

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1050947
(Reporter)

Updated

4 years ago
Keywords: intermittent-failure
You need to log in before you can comment on or make changes to this bug.