Closed Bug 1053261 Opened 5 years ago Closed 5 years ago

Implement default customisable default top sites

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: kgrandon, Assigned: daleharvey)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

From bug 1041620 comment 22

We're displaying hard-coded data for default top sites which was used for user testing. We need to re-implement the feature we have in the browser app to define default top sites at build time and on first SIM entry and hook this up to a real places database.
I will work on getting the operator variant setup, the carrier should not be able to customise history so we are gonna need a list of default top sites and assets for them and visuals for having blank history, sound good?
Flags: needinfo?(pdolanjski)
Flags: needinfo?(fdjabri)
Blocks: rocketbar-search-mvp
No longer blocks: 938288
Top Sites to preload (this puts us roughly inline with Fennec):
mozilla.org
support.mozilla.org

Do you need graphics assets for these as part of the preload?
Flags: needinfo?(pdolanjski) → needinfo?(dale)
Yup cheers
Flags: needinfo?(dale)
Hi Eric, could you provide the assets for mozilla.org and support.mozilla.org please?
Flags: needinfo?(fdjabri) → needinfo?(epang)
Francis, what do you think about adding find.firefox.com to that list (Find My Device page)?  The page itself is not refreshed yet, but it could be used to promote the service.  It probably wouldn't provide a huge amount of value beyond increasing awareness, though.
Flags: needinfo?(fdjabri)
Yuan, do you have the Fennec Top Site preload icons for mozilla.org and support.mozilla.org? 
Eric, we could re-use those if you think it makes sense.
Flags: needinfo?(ywang)
(In reply to Peter Dolanjski [:pdol] from comment #6)
> Yuan, do you have the Fennec Top Site preload icons for mozilla.org and
> support.mozilla.org? 
> Eric, we could re-use those if you think it makes sense.

Yes, this makes sense to me, might as well use them if we have them on fennec already.  If they don't look right I can away tweak the assets if needed, thanks!
Flags: needinfo?(epang)
Hello all,

I suggest to add http://support.mozilla.org/products/firefox-os as a bookmark/top sites link instead of support.mozilla.org.

Thanks
(In reply to Peter Dolanjski [:pdol] from comment #6)
> Yuan, do you have the Fennec Top Site preload icons for mozilla.org and
> support.mozilla.org? 
> Eric, we could re-use those if you think it makes sense.

Hi Peter, I am CCing Anthony on this bug. He's been leading the visual refinement project on top site tiles.
Flags: needinfo?(ywang) → needinfo?(alam)
(In reply to Peter Dolanjski [:pdol] from comment #6)
> Yuan, do you have the Fennec Top Site preload icons for mozilla.org and
> support.mozilla.org? 

Hey Peter!

I can get you those. What are they dimensions you guys need them in? Or do you just want the wordmark with no background color and then resize it yourselves?
Flags: needinfo?(alam) → needinfo?(pdolanjski)
Hi Anthony,

Great!  Eric would know for sure, but I'm thinking the latter is good so that he can just resize it.
Flags: needinfo?(pdolanjski) → needinfo?(epang)
(In reply to Peter Dolanjski [:pdol] from comment #11)
> Hi Anthony,
> 
> Great!  Eric would know for sure, but I'm thinking the latter is good so
> that he can just resize it.

Yes, that works for me!  Anthony, if you can email me the assets I'll be good to resize.  Thanks!
Flags: needinfo?(epang) → needinfo?(alam)
Since the topsites have been removed already, renaming this to track implementation efforts.
Summary: Remove hard-coded top site/history data → Implement default top site/history data
^ eric, I just found them in the dropbox too, let me know if these aren't good enough but they should be :)
(In reply to Anthony Lam (:antlam) from comment #15)
> ^ eric, I just found them in the dropbox too, let me know if these aren't
> good enough but they should be :)

Thanks for finding these Anthony, these are great!
Flags: needinfo?(epang)
Attached file Top Site Assets.zip
Hi Dale,

I've attached top site assets for Mozilla Support and Mozilla.org.

Let me know if anything else is needed.  Thanks!
Flags: needinfo?(dale)
(In reply to Peter Dolanjski [:pdol] from comment #5)
> Francis, what do you think about adding find.firefox.com to that list (Find
> My Device page)?  The page itself is not refreshed yet, but it could be used
> to promote the service.  It probably wouldn't provide a huge amount of value
> beyond increasing awareness, though.

I'd prefer not to point to it until it's ready, otherwise this might just feel like spam.
Flags: needinfo?(fdjabri)
Blocks: rocketbar-mvp
No longer blocks: rocketbar-search-mvp
[Blocking Requested - why for this release]: 

This is a feature we lost when moving the browser, it kept getting looked over in triage, taking now and will get it done asap
Assignee: nobody → dale
blocking-b2g: --- → 2.1?
Flags: needinfo?(dale)
Summary: Implement default top site/history data → Implement default customisable default top sites
blocking-b2g: 2.1? → ---
Not a blocker but will ask for uplift when we have a new patch (Late feature)
Target Milestone: --- → 2.1 S4 (12sep)
confirmed regression -> blocker. Poor UX
blocking-b2g: --- → 2.1+
Dale - don't we need to ship with all of the asset sizes? @1.5x, @2x, etc?
Flags: needinfo?(dale)
So we havent had the ability to change the customised files loaded based on their resolution up till now, at least the old browser used a single asset file, however during the build step we could pick up the correct resolution I guess
Flags: needinfo?(dale)
(In reply to Dale Harvey (:daleharvey) from comment #24)
> So we havent had the ability to change the customised files loaded based on
> their resolution up till now, at least the old browser used a single asset
> file, however during the build step we could pick up the correct resolution
> I guess

The right asset files should automatically be included in the build-step assuming ordering is correct and we're pulling from the right directories. Let me look into it a bit more, might just be a few calls/checks we need to make.
I updated build.js to pick up the correct resolution tile if available, and added them to the build
Comment on attachment 8486316 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23848

So I think we should land with proper resolution picking using the GAIA_DEV_PIXELS_PER_PX option. Re-flag me for review if you think we should land before then. Thanks!
Attachment #8486316 - Flags: review?(kgrandon)
Comment on attachment 8486316 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23848

(In reply to Dale Harvey (:daleharvey) from comment #26)
> I updated build.js to pick up the correct resolution tile if available, and
> added them to the build

Oops, did not see that. Re-flagging myself for review then :)
Attachment #8486316 - Flags: review?(kgrandon)
Comment on attachment 8486316 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23848

(In reply to Dale Harvey (:daleharvey) from comment #26)
> I updated build.js to pick up the correct resolution tile if available, and
> added them to the build

I don't see the new assets or logic in build.js. Was this updated?
Attachment #8486316 - Flags: review?(kgrandon)
Comment on attachment 8486316 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23848

Apologies, push failed due to crappy internets
Attachment #8486316 - Flags: review?(kgrandon)
Comment on attachment 8486316 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23848

Please fix up a few issues on github and re-flag. Thanks!
Attachment #8486316 - Flags: review?(kgrandon)
Comment on attachment 8486316 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23848

Addressed the github issues, cheers
Attachment #8486316 - Flags: review?(kgrandon)
Comment on attachment 8486316 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23848

Looks like we are in a good state now, thanks!
Attachment #8486316 - Flags: review?(kgrandon) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/bc549370546e6d2a8944f12a0e8d2d91b223ef5a
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8486316 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23848

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Late feature.
[User impact] if declined: Users will have an empty top sites list with a new device which is a pretty poor user experience.
[Testing completed]: Manual verification on device.
[Risk to taking this patch] (and alternatives if risky): Low risk as this is contained within the search browser page which is a new feature.
[String changes made]: None.
Attachment #8486316 - Flags: approval-gaia-v2.0?(fabrice)
Attachment #8486316 - Flags: approval-gaia-v2.0?(fabrice) → approval-gaia-v2.0?(release-mgmt)
Did you mean to request this on v2.0 or v2.1?
Flags: needinfo?(dale)
Comment on attachment 8486316 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23848

I really am fumbling with these flags today, aren't I? :)

2.1 seems correct, see comment 35 for approval form.
Attachment #8486316 - Flags: approval-gaia-v2.0?(release-mgmt) → approval-gaia-v2.1?(release-mgmt)
Flags: needinfo?(dale)
Comment on attachment 8486316 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/23848

Requesting QA verification once this lands on 2.1
Attachment #8486316 - Flags: approval-gaia-v2.1?(release-mgmt) → approval-gaia-v2.1+
Keywords: verifyme
Depends on: 990047
Issue verified as fixed on Flame 2.1 and Flame 2.2

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


On first browser launch the new page screen shows top sites as Mozilla Support and Mozilla.org with correct visual assets.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.