Closed Bug 105332 Opened 21 years ago Closed 21 years ago

stack trace should have a bug on file [@0x10101010]

Categories

(Core :: JavaScript Engine, defect)

x86
Windows 98
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 90378

People

(Reporter: timeless, Assigned: khanson)

References

()

Details

Incident ID 36818979
Stack Signature 0x10101010 a1f089e1
Bug ID
Trigger Time 2001-10-17 08:22:59
Email Address jsoref@wgate.com
URL visited selecting all 166 messages from pop inbox to move to localhost
User Comments
Build ID 2001100906
Product ID MozillaTrunk
Platform ID Win32
Trigger Reason Access violation
Stack Trace
0x10101010
js_GetSlotThreadSafe [d:\builds\seamonkey\mozilla\js\src\jslock.c, line 511]
JS_GetPrivate [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 1893]
js_CloneFunctionObject [d:\builds\seamonkey\mozilla\js\src\jsfun.c, line 1934]
JS_CloneFunctionObject [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2751]
DefinePropertyIfFound
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 455]
DefinePropertyIfFound
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 388]
js_LookupProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2202]
js_SetProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2472]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2578]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 827]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 902]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3389]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 980]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 160]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1251]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
2047]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3680]
nsEventStateManager::ChangeTextSize
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 1160]
nsEventStateManager::PreHandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 380]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5717]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5569]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 392]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 365]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 2094]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 83]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 749]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 766]
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4314]
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4564]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3277]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 1014]
KERNEL32.DLL + 0x363b (0xbff7363b)
KERNEL32.DLL + 0x24407 (0xbff94407)
0x00688b5e 

sorry no steps.
Reassigning to Kenton - 

cc'ing jpatel - Have you seen this stack signature recently?  Thanks -
dupe of bug 90378 
(if I compare the stack from:fenella@netscape.com 2001-07-11 14:15)

*** This bug has been marked as a duplicate of 90378 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Verified Duplicate - stack trace at 2001-07-11 14:15 in the other bug
is identical from nsXULElement::HandleDOMEvent() on up
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.